Error while running Knime in batch mode

Hi,

I am currently running Knime in batch mode. I have 5 almost identical worklows and when running, a couple worklfows generate this error:

ERROR KNIME-ConfigurationArea-Checker ConfigurationAreaChecker Can’t check integrity of configuration area (“C:\Program Files\KNIME\configuration”): The process cannot access the file because another process has locked a portion of the file
java.io.IOException: The process cannot access the file because another process has locked a portion of the file
at sun.nio.ch.FileDispatcherImpl.write0(Native Method)
at sun.nio.ch.FileDispatcherImpl.write(FileDispatcherImpl.java:75)
at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:93)
at sun.nio.ch.IOUtil.write(IOUtil.java:65)
at sun.nio.ch.FileChannelImpl.write(FileChannelImpl.java:211)
at org.knime.core.internal.ConfigurationAreaChecker.lambda$0(ConfigurationAreaChecker.java:135)
at java.lang.Thread.run(Thread.java:748)

My script looks like this:
“C:\Program Files\KNIME\knime.exe” -nosave -consoleLog -nosplash -reset -application -clean org.knime.product.KNIME_BATCH_APPLICATION -workflowFile=“C:\Users\x\y\workflow.zip”

I have tried searching for the solution on Knime forums, but couldn’t find anything that works. Has anybody encountered and fixed this error?

Just to add: this occurs at the very last step of the workflow - DB writer. So the whole workflow seems to be ok. Also, when running the workflow in Knime, everything works well

have you tried -workflowDir="…"

Yes, it produces the same error.

Hello @wytux10,

Have you tried to call the Workflow and not a zip-File?

BR,
Sven

Hi @wytux10 and all, I don’t think there is an issue with calling the zip file or the workflow directly. As @wytux10 mentioned, the workflow is executing, but fails on the last step of the workflow. So I think it might be an issue with some file manipulation inside the workflow where some file might be used/locker.

Can we see what the workflow is doing? Also, is this a shared instance of Knime?

Thank you for your answer, but I was able to fix this problem.

I uninstalled Knime (during uninstall Knime was unable to delete configuration folder), closed all the processes of Knime in the task manager, deleted the configuration folder and then reinstalled Knime. So it seems to me, that there were some background processes running which were locked the configuration folder.

Hi @wytux10 , glad to hear that you were able to resolve it, though via the extreme resort of having to uninstall and reinstall Knime.

From what you are saying though: “closed all the processes of Knime in the task manager”, it sounds like the multiple instances could have been the issue, this is similar to running Knime as a shared instance (hence why I was asking if that was the case), so each instance was competing with each other and one of them must have locked the file/folder.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.