Error While trying to connect with knime server

This error occurred when I trying to connect with the knime server.

When I open dialog of Edit mount point i got an error ,which i specified in above SS.

Hi @KashyapGohil.

can you reach the server webportal with a browser (Firefox/Chrome)?
Is the server online and running?
What is you client and server version?

Here’s the version info: image. I’m not understanding how to check if the server’s running or not, as the http://localhost:8080 is not returning anything, when I try to access in the Browser.

Is this platform dependent? As I’m running on Ubuntu 20.04 LTS. All the tutorials are available only on Windows.

Hi @KashyapGohil,

is the knime server running on the same machine?
Then you should be able to access the webportal through:

or http://serverip:8080/knime
as well as a defined url set in the setup of the server

if you cannot reach it - most likely the server is not running or reachable

No - Ubuntu should run just fine as it does on Windows (at least it does for our linux server)

What is the version of the knime server?
Could you check if the server process is running?
(you need to have a server installed and running somewhere before you can connect! - just saying to make sure…)


As mentioned,

  1. Make sure that the KS is up and running. You can verify this if you go to http://:8080 and get the Apache Tomcat generic page, or go to http://:8080/knime and get the webportal login page. If it’s not running, well, you’ll need to go fix that first. :slight_smile:
  2. In AP, go to the KNIME Explorer and click on the page-with-green-checkmark icon and get to the list of configured mount points.
  3. click ‘new’.
  4. in ‘server address’, enter eithr http://:8080 or https://:8443 and hit Enter. it will automatically submit a REST request to that server and grab the Mount ID to populate it, then you can return to the list of configured mount points.
  5. click OK and go try to login to your new server definition through KNIME Explorer.

Let us know if none of this helps.


1 Like

Note that in my previous response, forum HTML formatting ate my URLs.
Instead of ‘http://:8080’, it should be ‘http://<server>:8080’.

Knime server is running but the port is not exposed that’s why this URL is not responding.

Hello Kashyap,

Is this to say, then, that you have identified the issue and have taken steps to resolve it? (I’m just trying to determine if you still need further assistance.)


Hi Nickolaus,

Unfortunately our issue on server side in still not resolved.
We have followed all steps and installed knime server on our local machine (i.e baremetal server)
by following all steps from
We did this successfully Knime server installation
but when we try to run Knime on our local server, we are facing following error

It seems error is related to port (8080) , which may not be exposed when we try to run on localhost
hence when we try to connect knime server from localhost, it is not able to connect


You mention ‘we are facing following error’, but, unless I am drastically missing something, what I see is a perfectly normal, working, successful KS service start.

You mention ‘error is related to port 8080, which may not be exposed’, but the default server.xml sets the ports (default http/8080 and https/8443). You can change these as needed, but I am suspecting this may not be the true issue, either.

Am I correct in thinking that what you are truly reporting is that, while your KS service is started, you’re just not able to get into the webportal, even from being ssh’d into the serverhost?
From ssh on the serverhost,
curl http://localhost:8080/knime/
should produce the same result (the main web page) as
curl http://<serverhost_public_hostname_or_ip>:8080/knime/

You should see the same result from both sides (internal and external, respectively).

If you don’t see it externally, it could be a firewall/networking issue.
If you don’t see it internally, then maybe you can contact us at and we can troubleshoot further over a video call.

Thank you,

1 Like