Error with Keras Network Learner -

I keep getting an error when executing Keras Network Learner with the following error message. “ERROR Keras Network Learner 3:32 module ‘keras.optimizers’ has no attribute ‘Adam’
Traceback (most recent call last):
File “”, line 7, in
AttributeError: module ‘keras.optimizers’ has no attribute ‘Adam’

ERROR Keras Network Learner 3:32 Execute failed: An error occured during training of the Keras deep learning network. See log for details.”

I guess it’s a problem with my Keras and Tensorflow2 preference setting. Below is the current configuration.

My current version of KNIME is version 4.7.1, and the Keras-relevant KNIME extensions are as follows:
knime Deep Learning - Keras Integration 4.7.0
knime deep Learning - Tensorflow Integration 4.7.0

Any feedback at all would be greatly appreciated, thank you!

Hello @MRAZ and welcome to the KNIME Community!!!

The Keras integration is based on TF1. Can you please try to create a new environment using the “New Environment…” button in the Keras section and use the newly created env for the Keras setting?


1 Like

Thank you for your help. I attempt to create new env for Keras by using the “New Enviroment…” as you suggested. Knime created warning message as attached.

I guess it should be possible to create a new Keras environment via conda, right?

Thanks for your help

Hello Kathrin,
I solved the problem where the keras environment could not be created because of the openSSL issue. And run the knime’s workflow ‘L4-DL Introduction to Deep Learning’, there are 2 warning and 2 error as follow.

Very grateful!

1 Like

The keras problem has been solved. Thanks for Kathrin’s help. Finally, a new environment was created through KNIME, which is a new environment based on the CPU. The above error message appears for new environments with GPUs. Is it a communication problem between Knime and the built-in Python? First use the CPU environment to learn. Thank you


great to read that you were able to set it up correctly.

Regarding the GPU support there are some requirements, which you can find here in our documentation: KNIME Deep Learning Integration Installation Guide



Any particular reason KNIME is using TF1, just curious.

1 Like

@Daniel_Weikert no I’m not aware of any particular reason.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.