Error with saving workflow

After creating a workflow, when I try to save it, I get the following error message :- “Can’t write workflow because the directory can’t be locked”.
I am using KNIME v 3.7.1. on a Windows machine.

Any advice/ help will be greatly appreciated.


It could be another instance of KNIME is running and accessing the folder or you are lacking write privileges. Have you tried a reboot?

Does this happen on a KNIME server or a local client.

Hi Thanks for the reply. Let me check those possibilities. This happened on a local client.

Thanks again,


Hi Melvi!

Have you solved it? Seems to me like problem with privileges. Company machine or private one?


Hi Ivan, Sorry for the delayed response. Yes it is a company machine; but I do have write privileges to the folder I am trying to access. I see this problem when I am trying to save a workflow after modifying it with another name.

Could it be a solution to only change the name of a workflow ‘offline’ or after you freshly opened KNIME. I can think about very large workflows where there might be a problem when changing the name of the central folder and every other think also has to change while KNIME is trying to update its list of folders and workflows. Could be that this refers is interpreted as something ‘accessing’ the folder and so restricting the possibility to rename it?

Hi there!

Just to see if I got it right. You take existing workflow, modify it and then go to Save As and when you chose location and name and click OK you get error? Can you share a print screen of error? And when you only copy paste workflow from within KNIME Explorer window what happens?

Additionally can you create a new workspace and try same thing on it to check if it is workspace related or not.