Error with Twitter Search Node, runs successfully, but no profile image shown

Hi all,

I am new to using the Twitter Knime Extention, so I was wondering why is my Knime twitter extension “Twitter Search” not working properly?

When I run the configuration, with my Twitter developer API keys and token, the results returned from the run have all the information except the user profile image.
Here is the configuration I had done:


Here is the result:

I had even tried using my friend’s Twitter API key to see if it works, as I had thought it was something to do with the Twitter developer account “permissions”, which my account is an "elevated account, but even when using my friend’s Twitter API key which worked for him, it does not work on my end.
The same configuration used:


The result using my friend’s API key:

Here would be an overview of the nodes used:

I am not sure what I should do to solve this issue, as I had tried to uninstall and then reinstall the Twitter and Textprocessing extension packages, which did not work. I had also uninstalled the KNIME software itself and reinstalled it, but it also did not solve this issue. May I know what can I do to fix this issue?

Thank you for your time to read through this query that I have. I hope that this problem that I am facing can be rectified/ solved. Thank you.

Hi @Filbert and welcome to the KNIME Community Forum,

does your friend uses KNIME Analytics Platform as well to access the Twitter API?

Cheers
Kathrin

Hi there Kathrin, yes my friend does use the same KNIME Analytics Platform as well to access Twitter API. We were if using this as it was another method of extracting tweets besides using the platform R Studio.

Even though my KNIME Analytics Platform “application” is of the latest version, similar to my friend, my tweet extract does not extract out the user image, while my friend was able to do it on his end.

Could it be because of some settings that I had configured unknowingly?

I hope that the problem that I am facing would be resolved, and thank you for the reply regarding the issue that I am currently facing.

Hi Filbert,

thanks for the additional information. That is strange indeed! I’m not aware of any setting that you might have set incorrectly.

Can you please do one more test for me and ask your friend to export his workflow and execute his workflow on your pc? Do you still run into the same issue?

If yes, are you both using the same operating system?

Thanks
Kathrin

Hi @Filbert , in your screenshots, can you instead show us the Specs tab so we can see all the columns that it’s returning?

Hi Kathrin, I am sorry for the late reply. I have ask my friend to export his workflow and execute the workflow on my PC, but the same result still occurs.

The configuration of the node:

Result when run:


Results in Spec format:

Overall Workflow:

I have asked him regarding the version of the KNIME Software, the latest version, which is the same one I am currently using. However, he is currently using Windows 11 while I am using Windows 10. Could that be why some function does not seem to work on my end?

Thank you for the time to read through this message, I hope that the problem I am facing will be resolved. Thank you.

Hi Bruno29a, thank you for trying to help out with the issue I am facing.

Regarding what you have asked for,

This is my Specs tab that was returned from my workflow:

And this is the Specs tab that was returned from my friend’s workflow:

I hope this does help in finding the reason why I am facing this issue.

Hi @Filbert , thank you for the screenshots.

It looks like you are getting the same fields as your friend, and there seem to be a “User - Profile image” column there. Is there anything that you can see in that column?

EDIT: Sorry @Filbert , I re-read the whole thread carefully and check out your original screenshots. I originally thought that the columns were not being returned, but I see that they are there in your original screenshots, but they’re empty.

Can you check if you have KNIME Image Processing extension installed?

It could be that they are just not being rendered, though Knime would have given you a warning about it.

The other thing that I can think of, could it be that the sample data you are looking at simply do not have any images?

1 Like

Hi @bruno29a, I have tried your recommendation of installing the KNIME Image Processing Extension, but when I run the node again, there is still no image shown.

Image Processing Package installed:

Run the Node:
image

Result Returned:

Regarding the other possibility that you have mentioned, when I have searched for the user Name extracted from the Twitter Node, I do see a profile image being returned.

The Twitter user of Row 1 has a profile image, but it is not shown in KNIME Twitter Seach Node.
image

Thank you for your time in reading through this message, I am grateful for the potential solutions you have given, but it seems not to resolve the issue that I am facing. I hope you will be able to find some information from this message to help me solve this issue. Thank you.

Hi @Filbert , I’m not sure how the Twitter Search node works and what it does in the background, but can you try to read the images directly to see if your Knime is able to render the image?

You can try the Read Images node along with the Renderer to Image node

EDIT: Here’s a simple test you can do:
image

I used these 2 URLs as input:

https://forum-cdn.knime.com/uploads/default/original/3X/b/7/b72ca2acf26b03bc686e94e55596fb08ff240e49.png
https://pbs.twimg.com/media/FOMxH4lWYAAjoBP?format=png&name=large

Basically the first one is the image you posted, and the 2nd one is the image directly from Twitter.

The images render properly in the Read Images node: