Exactly numbers belonging to the bars in the bar chart

Hi guys,

I’m quite new to the whole knime topic. But I have a lot of fun to try new things and explore everything. And so far, google helped me a lot with my questions. except for one question: How can I export my bar charts with the exactly numbers per bar in an image?
Because if I use the Image Writer (Port), I only get an image without the respective numbers belonging to the bars. Do you have any ideas, how I could solve this problem?

Thank you very much und kind regards,
Tim

Hello @tc020,

under General Plot Options tab there is option Display static bar values option. Enable it and upon export you’ll see bar values. Only it seems that implementation is done in a way that max value is displayed inside bar while other values are above it. Minor detail but still bothers me a bit :smile:

Welcome to Community!

Br,
Ivan

5 Likes

Hey @ipazin,

the case you are describing with the value rendered inside the bar only happens for stacked bars, correct?
The general logic is implemented in a way that it tries to render the values above the bar and only renders them inside the bar if the space above the bar is too small.

Greetings,
Daniel

1 Like

Hi @ipazin ,

thanks for your advice. But it seems so, that I don’t have this option :thinking:

Best,
Tim

1 Like

Hello @tc020,

it was introduced with KNIME version 4.6.0. (AP-14913) so would say you have lower version. If it’s possible update your KNIME and you should see it.

Here is the link to 4.6.0. changelog:
https://docs.knime.com/latest/analytics_platform_installation_guide/index.html#_knime_analytics_platform_4_6_0

And in general here is link to list of changelogs:

Hello @DanielBog,

Nop.

Br,
Ivan

3 Likes

Thank you very much @ipazin !! :slight_smile:

1 Like

Hey Ivan,

thanks for sharing the screenshot. Makes sense and we went for this approach to not impact the domain. I get why this is annoying and will try to improve it for the new Bar Chart we are currently working on.

Greetings,
Daniel

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.