Examples Server - Stuck Fetching Content

#1

Hi KNIMErs

I just upgraded to 4.0.2. and the Examples Server does not appear to be able to connect. It keeps showing ‘Fetching content…’ but never completes.

I’m hoping for some guidance on how to get this working, I’m assuming there is a quick fix for this so I don’t have to reinstall everything and my settings! Thanks!

image

0 Likes

#2

Hi,

from which KNIME Analytics Platform version did you upgrade? With KNIME Analytics Platform 4.0 we moved the EXAMPLES Server to KNIME Hub, whereas for older versions we still use the previous EXAMPLES Server. Have to tested it with a fresh installation of KNIME Analytics Platform?

Do you know if you are behind a firewall that might block the fetching of the content for some reason?
Are you able to connect to My-KNIME-Hub (simply use your forum login)?
Does the error still occur?
We will also check if there has been some problems with KNIME Hub around that time.

Btw., you can also export and import your preferences into an .epf file in case you want to backup your KNIME preferences, in case you ever have to re-install it.

Cheers,
Moritz

2 Likes

#3

Thanks @moritz.heine. I was not aware the Examples Server was no longer used in 4.0. The Hub connection works just fine for me. You’ve saved me a potential reinstall for a problem that doesn’t exist!

Note to KNIME: If Examples Server no longer works in 4.0, could it be removed to prevent confusion for other users?

1 Like

#4

Hi,

sorry for the misunderstanding. The EXAMPLES are still there in 4.0, but they changed location to be on KNIME Hub. While for the average user this might not be a problem, we encountered that some users which sit behind a firewall or something similar encountered problems as the firewall was blocking it.

So if you can connat to My-KNIME-Hub you should be also able to connect to EXAMPLES. If this still doesn’t work for you, there seems to be another problem. You can also see it is the correct EXAMPLES server if the address behind it shows ‘hub.knime.com’, which it does according to your screenshot.

Cheers,
Moritz

0 Likes

#5

@supersharp, to be clear, “Examples (knime@hub.knime.com)” should work. In Analytics Platform starting with v4.0, we’ve moved the fetching of our public examples to the KNIME Hub.

Have you tried to connect to the Examples again since your original post? Do you still encounter any problem with the fetch hanging or taking longer than a few seconds to complete?

0 Likes

#6

Hi @jtyler

I have tried opening the Examples multiple times from within KNIME Analytics Platform, but no luck. It says ‘Fetching content…’ but never returns the examples. I can access the browser directly with no issues and IT confirms there is no firewall restriction to the site.

Perhaps there are some legacy preferences as I migrated my preferences from version 3.7.2 which is causing a conflict in the back end? Or some settings I need to verify with the new version? Thanks for your help.

0 Likes

#7

Hi,

could you check your installed extensions for KNIME Server Space?
Just go to Help -> About KNIME Analytics Platform -> Installation Details.
With KNIME Analytics Platform 4.0.2 you should have version 4.9.1.v201908131250.
Could you also try it out with a new workspace or a new installation + workspace?

Cheers,
Moritz

0 Likes

#8

Hi @moritz.heine,

  • I have the correct Server Space version: KNIME Analytics Platform 4.0.2 => version 4.9.1.v201908131250
  • I also tried switching workspace to a brand new workspace, but there was no difference
  • So I believe this leaves me with a new installation + new workspace as my last resort, unless there are other things. Will likely try this in the next few days if no other suggestions pop up.
    Thanks!
0 Likes

#9

Hi,

you could also just download an archived KNIME Analytics Platform so you don’t have to uninstall your current installation in case you just want to try it out.

Could you also check the version of the following plugin for me: KNIME Server API.
You can find it under the Plug-ins tab of the Installation Details dialog. Simply search for ‘server api’

Cheers,
Moritz

0 Likes

#10

Here’s what I see:

0 Likes

#11

Hi,

sorry for the late reply. This seems to be only the sources for the plugin and it even seems to be an outdated version. It’s rather weird that the KNIME Server REST API doesn’t show up (without the ‘Source’).
Have you tried a new installation already?

Cheers,
Moritz

0 Likes

#12

Hi moritz
Spoke to Thomas R. in person at the summit, he recommended to check out the log. Are you able to help?

2019-11-07 12:38:12,592 : WARN : KNIME-Worker-1 : : TipsAndNewsInjector : : : Could not modify intro page: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1946)
at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:316)
at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:310)
at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1639)
at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:223)
at sun.security.ssl.Handshaker.processLoop(Handshaker.java:1037)
at sun.security.ssl.Handshaker.process_record(Handshaker.java:965)
at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1064)
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1367)
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1395)
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1379)
at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnectionImpl.java:162)
at org.knime.product.rcp.intro.TipsAndNewsInjector.prepareData(TipsAndNewsInjector.java:220)
at org.knime.product.rcp.intro.AbstractInjector.run(AbstractInjector.java:145)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at org.knime.core.util.ThreadPool$MyFuture.run(ThreadPool.java:123)
at org.knime.core.util.ThreadPool$Worker.run(ThreadPool.java:246)
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:397)
at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:302)
at sun.security.validator.Validator.validate(Validator.java:262)
at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:324)
at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:229)
at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124)
at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1621)
… 16 more
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:141)
at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:126)
at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:280)
at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:392)
… 22 more
2019-11-07 12:38:36,068 : ERROR : main : : MAEFileUtils : : : Schrodinger Knime plugins: Neither SCHRODINGER environment nor preference is set. You can set SCHRODINGER installation location in the Schrodinger Preferences.
2019-11-07 12:38:36,083 : WARN : main : : SchrodFileUtils : : : SCHRODINGER is not set properly.
2019-11-07 12:38:36,083 : WARN : Thread-5 : : PythonService : : : PythonService is not initilized
2019-11-07 12:38:36,083 : WARN : Thread-5 : : PythonService : : : Failed to start python service.
2019-11-07 12:38:39,978 : WARN : Worker-14 : : Configuration : : : Unable to load plugin configuration from NodePit. Use last known or default settings instead.
2019-11-07 12:38:47,371 : WARN : Worker-27 : : Configuration : : : Unable to load plugin configuration from NodePit. Use last known or default settings instead.

0 Likes

#13

Hi,

thanks for the error. While this is related to tips and tricks this might be related to the Examples Server.

Could you please answer the following questions:

  • From which KNIME Server version did you upgrade to 4.0.2?
  • Could you provide me with the version of the KNIME Server REST API plugin? In your previous reply you showed the version for the Source.
  • Did you try it out with a new installation?

Could you also check, that you don’t have accidentally changed your software update sites with the imported preferences?
The default URLS can be found here:

Cheers,
Moritz

0 Likes

#14

Hi @moritz.heine

I have now tried a reinstall (it uninstalled my previous versions), and the use of a brand new workspace. I still cannot access the Examples Server from within KNIME - still get the ‘fetching…’ status and it doesn’t open.

To answer your questions:

  1. I am strictly using KNIME AP - and not KNIME Server. The old KNIME AP version was 3.7.2
  2. I think this is what you are asking? Otherwise please guide me as to where to find this detail?
  3. Tried a new installation and a new workspace
    Software update sites are as follows - it looks correct

Thanks!

0 Likes