Hello, I have a lot of experience using drag and drop platforms and was used to using IBM’s SPSS Modeler for many years. Recently I got to know KNIME and everything was fine until I tried to export my analyses to Excel or CSV files. I don’t know what happens, but always get an error. I’ve already created a new Workspace, I’ve just tried removing the missing values, but nothing solves this problem. I’ve built a workflow with almost 600K records and I can’t export it. Please help me with this. I’ve read several messages here on the forums, but I’ve had no success in solving this problem. The error messages are always something like “Illegal char : > at index 54…”. This number at the end of the message always changes and all attempts fail, no matter what configuration changes are made.

I did a test with the Excel Write node right at the beginning of the workflow and noticed that the export worked. I’ve been connecting the export node at each step and saw that the error happens right after a concatenate node. I don’t know what happens after the files are joined, but exporting is not possible from this point forward. My suspicion is that there is some bug with the base concatenation node, because when there are incompatible columns the values are filled with “?”.
Even using the Missing Value node for correction the export gives error.

Hi @dgentil and welcome to the forum.

The error message in your workflow means that KNIME is trying to write to a malformed path. If you look closely at the the error, you can see that it starts with
C:\Users\Daniel... and later on contains F:\KNIME\... - like 2 different paths joined together. This happens because you’ve chosen to write relative to the current workflow in the options above, but what you really want to do is write to the Local File System instead:

2023-11-01 10_28_53


Hi, @ScottF! Thank you very much for your cooperation. But I have to disagree about the cause of the problem. After performing some tests by changing the Excel Writer node position, I realized that the error appears right after inserting the concatenate node. Take a look at the images I’m providing and you’ll notice that I don’t change any of the Excel Writer node’s settings, apart from its position in the flow. The export works perfectly (image with the red line). However, whenever I change the connection to after the concatenate node, the error occurs again and again. I enabled the monitoring console and got the following error message: “Execute failed: Unsupported column type ‘?’. Please remove corresponding column(s) from the input table.”. I insist that this error may be associated with the appearance of this “?” character in the columns resulting from the concatenation process. And, as I said, even using the Missing Value Node, the error persists. Thanks again for the tips and quick replies.

I’m fairly certain we are dealing with two separate errors here - the first dealing with malformed paths as I described.

This second error sounds like unknown column types (?) created during Concatenation. This often happens when KNIME has identified the same-named columns as different types (perhaps string and integer) due to the contents of the data files. What you can do to alleviate this is force column types when you read the data (using the Transformation tab of the Excel Reader) or by direct conversion afterward (using for example a String To Number node). Then the ? data type will be resolved and the Excel Writer will work.

If you need more assistance, consider exporting and uploading your workflow directly - assuming you are not dealing with confidential data - and folks here will be able to provide more specific help, instead of just educated guesses. Screenshots are useful for diagnosis, but only to a point. :slight_smile:


@ScottF , once again I thank you for your patience and for all the attention given to my case. I’ll try to apply the suggestions you’ve made. If I don’t succeed, I share the workflow here to make it easier. I thank the whole community in advance and I hope to be able to contribute someday. See you!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.