Excel reader is reading just first few rows

Good Day Knimers :green_heart:!

Now I am having an issue with excel reader. The node is not reading whole content, just in case I checked the same file in alteryx, it works fine.
I was not able to upload it, so file in google drive:

In Alteryx:

After checking in Alteryx I extracted sheet as an output, and I tried to read in KNIME, here it scanned and read properly.

So, can you help me read this file wo going to Alteryx
P.S. I did not change anything in the file itself (downloaded and started to read it)

Many Thanks,

Hi @Karlygash,

the Sheet you shared is private (at least i cannot view it :slight_smile: )



Just guessing based only on the screenshots, it looks like you have some header records at the top of the file. If you uncheck the box for “Table contains column names in row number X” and choose to read only data starting from, say, row 9, does it perform any better?


Hi, @ScottF . I tried it, but it is still no records

hi @AnotherFraudUser
sorry, i have changed access

I was able to download your file and do a quick check. Can you try unchecking the “Skip hidden rows” checkbox under the Advanced Settings tab? That seemed to do the trick for me.


@ScottF I think you are correct here. At least from another outside perspective this looks like the solution :+1:


@ScottF , wooow cool! thanks!!! :innocent:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.