Excel Reader Node doesn't load data table

Hello all,

I’m facing some issues with my Excel Reader Node. After resetting one of my workflows, the settings for the xlsx-path have disappeared. After specifying the path once again, the node won’t load the data table. When clicking OK I get the following error message:

Can anyone help out how to solve this problem?
Thanks a lot in advance!

Hi @Ramona,

it looks like the versions of Excel and KNIME Analytics Platform are out of sync.
Did you have any issues when updating to 4.3.1?

Kind regards,


Hi @nemad ,

thanks for your help.
I’m still on version 4.3.0 and didn’t do the update yet.
However, I did install some extensions 2 or 3 days ago. Could that be the reason?
Do you think I could fix the problem by updating to 4.3.1?

Best regards,

It looks like your Excel node is already on version 4.3.1 because it tries to call a method that was introduced very recently.
An update to 4.3.1 should fix the issue.
May I ask which extensions you installed?
I am trying to understand how the Excel Reader could end up with a newer version than the base installation.


1 Like

Thank you, Adrian!
I’ll do the update and I’m sure the problem will be fixed afterwards.

I installed all the extensions of the following groups: KNIME & Extensions, KNIME Community Contributions - Other and KNIME Lab Extensions.
During installation I checked the following solution:


I assume it would have been better to check the second option!?
Best regards, Ramona

I’d recommend to update to the latest bugfix release of the minor version you are using.
That means if you have 4.3.0 and you install something new after we released 4.3.1, it would be best to update your entire installation to 4.3.1, in order to make sure that all versions match.

Best regards,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.