Excel Reader Node doesn't refresh the data when reset and executed again.

Hello,

Currently I’m facing an issue with KNIME excel reader node. It doesn’t read/refresh the updated file when the node is reset and executed again. In fact, I need to open the configuration and click ‘Ok’ again, only then the data is refreshed. Does anyone know the cause? My assumption is probably this is a bug in excel reader node in KNIME 4.4.4.

1 Like

Hello @hizkiakusnadi ,

welcome to the Forum!

Although we don’t know of any such problem internally, maybe it’s worth using the latest version which is 4.6.1. now.
Back to your problem I am not sure what you mean on “open the configuration and click ‘OK’”? Do you mean you do right click on the node / than hit “Execute”? Or you mean you have to give the input location of your file again (right click on the node / Configure / Input location / OK)?

Regards,
Dora

1 Like

So, the problem is when I reset and execute again the node by doing: right click → reset node → execute, the excel reader node doesn’t refresh the data (even though I changed some column names in the data source excel file).
However, when I do: double click on excel reader node → click Ok/Apply, then it refreshes the data. Which is kind of strange, because the excel reader node should have refreshed the data when reset and executed again.

1 Like

You would have to allow changing data schemes.

1 Like

Can you please share with me on how to do that?

You would have to allow “changing file schemas” on the “Advanced Settings” tab.

4 Likes

I often have the same problem for excel reader node, and I can not to allow “Support changing file schemas”, otherwise my subsequent nodes will fail, that’s been bothering me for a long time.

@Mingu welcome to the KNIME forum.

Could you elaborate what failure further down your workflow means? Can you provide us with a sample workflow (without spelling any secrets) and/or a logfile about what happens.

If the structure of your Excel file would change you might have to reflect that in your workflow or maybe just keep the columns that would not change.