Excel Reader Node fails to read-in several files in a folder

Dear KNIME community,

I ran into difficulties reading in several Excel files at once with the Excel Reader Node.

The Error is “The following columns are not contained in all source files: [H, I, J, K, L, M, N, O, P]”
This doesn’t make sense to make since:
a) these columns are empty in all 3 files and should thus be ignored
b) even if I explicitly tell it only to use columns A to G, the error persists


Advanced Settings:

All excel files have the same header:

Thank you for your time and help.

@romba050 welcome to the KNIME forum

If this is the case then you might have to tell the Excel Reader to do that on the advanced settings tab:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.