Excel Reader Not Working

I’m trying to drag the Excel Reader onto my workflow and it just gives me the “The selected node could not be created due to the following reason: null” . I’m on 4.3 and have uninstalled and reinstalled without any success.

Should note that I am running the latest Knime version. File Reader works fine but Excel Reader and Writer both have the same error. The following log file:

2020-12-21 19:52:04,329 : ERROR : main : : WindowsDefenderExceptionHandler : : : PowerShell command powershell -inputformat none -outputformat text -NonInteractive -Command Get-MpComputerStatus -ErrorAction Stop | Select-Object -ExpandProperty AMServiceEnabled did not terminate successfully.
2020-12-21 19:52:04,330 : ERROR : main : : WindowsDefenderExceptionHandler : : : Stderr is:
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : : Get-MpComputerStatus : A general error occurred that is not covered by a more specific error code.
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : : At line:1 char:1
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : : + Get-MpComputerStatus -ErrorAction Stop | Select-Object -ExpandPropert …
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : : + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : : + CategoryInfo : NotSpecified: (MSFT_MpComputerStatus:ROOT\Microsoft…pComputerStatus) [Get-MpComputerS
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : : tatus], CimException
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : : + FullyQualifiedErrorId : HRESULT 0x800106ba,Get-MpComputerStatus
2020-12-21 19:52:04,331 : ERROR : main : : WindowsDefenderExceptionHandler : : :

Not sure if there is another way to read or load Excel files

This might indicate that there is a problem with the virus scanner. Maybe it is too aggressive towards the many small files KNIME consist of and does use with its workflows

You could also check out this collection about possible problems and how to deal with them and see if anything might be relevant:

You could use R to import Excel files and use them in KNIME. I add a collection of examples. But if you experience various problems with your KNIME installation you might have to address them first before turning to additional tools like R (or Python).

Thanks for the reply. I’ve shut down all firewall and anti virus after adding exceptions and still can’t get that set of nodes to work. I was able to drag an Excel file on to the workflow and just run it but can’t get the Configure window to open. Just gives me an error in the console.

ERROR NodeContainerEditPart The dialog pane for node ‘Excel Reader 0:6’ has thrown a ‘NullPointerException’. That is most likely an implementation error.

The log says:

2020-12-22 08:41:03,597 : ERROR : main : : NodeContainerEditPart : : : The dialog pane for node ‘Excel Reader 0:6’ has thrown a ‘NullPointerException’. That is most likely an implementation error.
at org.knime.workbench.ui.wrapper.Panel2CompositeWrapper.(Panel2CompositeWrapper.java:134)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.createDialogArea(WrappedNodeDialog.java:313)
at org.eclipse.jface.dialogs.Dialog.createContents(Dialog.java:767)
at org.eclipse.jface.window.Window.create(Window.java:431)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1094)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.create(WrappedNodeDialog.java:329)
at org.eclipse.jface.window.Window.open(Window.java:788)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.open(WrappedNodeDialog.java:199)
at org.knime.workbench.editor2.editparts.NodeContainerEditPart.openNodeDialog(NodeContainerEditPart.java:925)
at org.knime.workbench.editor2.actions.OpenDialogAction.runOnNodes(OpenDialogAction.java:129)
at org.knime.workbench.editor2.actions.AbstractNodeAction.runInSWT(AbstractNodeAction.java:174)
at org.knime.workbench.editor2.actions.AbstractNodeAction$1.run(AbstractNodeAction.java:160)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:236)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:133)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4561)
at org.knime.workbench.editor2.actions.AbstractNodeAction.run(AbstractNodeAction.java:157)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:474)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:579)
at org.eclipse.jface.action.ActionContributionItem.lambda$4(ActionContributionItem.java:413)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4105)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1037)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3922)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3524)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1160)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1049)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:658)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:557)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:154)
at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:176)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
at org.eclipse.equinox.launcher.Main.run(Main.java:1447)

@UtilityHawk this sounds like the installation is still not working, although the windows defender reports have disappeared. To be sure you might want to check your whole system besides KNIME for potential malware infections.

You may take a look at the points in the document about performance and problems and see if other workflows do work. A clean install from the ZIP file into a new folder maybe a thing.

You might also check your windows version and where your KNIME program and workflow are stored if they are on an external or removable drive or in a DropBox or OneDrive folder.

Then you could try and use a minimal workflow example, set the log level to DEBUG and share the workflow and the log with the community.

1 Like

Thanks. I did a complete reinstall and it looks to have resolved itself. I’ve updated it back to where I was and have the Excle nodes working again.


The new Excel Reader and Excel Writer are also unable to use session variables. Simply unable to select them. Option is greyed out.

What do you mean with “session” variables, @Terry99s?

My context to “session” variables is:

  • i create them in my flow - usually at the very beginning of flows
  • many times, we are using an Excel file to control the flows - using to set common parameters
  • Examples: 1st parm in excel file indicates which environment to connect to: Production, Test 1, Test 2, etc… 2nd parm indicates which user ID to use for the run 3rd parm indicates output file path to write to 4th parm indicates the output file name 5th parm indicates flow input file path (used for imports) etc…

Does that provide you with a proper answer? If you need more info/context, let me know. Glad to help.


Hey @Terry99s,

the Excel Reader (and other nodes of the new file handling extension) are using the new path flow variable type. You probably need to convert the string flow variables into paths variables using the String to Path (Variable) node.



@Terry99s maybe you can check out this example.

There is also an example with a new excel file reader, this seems to have a problem with a local or custom URL in contrast to a relative path.

@julian.bunzel there should be an open request (18169) with knime to investigate this.


Thanks for the suggestion. We’ve updated all Excel Readers using the new Path variables. We’re not trying to convert to the newer Excel Writer and encountering issues when attempting to write out to a remote SharePoint site Folder. Any thoughts?

Hey Terry,

sorry for the late response. Can you give me some more information about what’s not working for you? There are some known problems with the new Excel Writer and SharePoint which will be fixed with 4.3.1. I hope your issues are gone then as well.
In the meantime, I’d recommend to check the workaround posted in the linked thread.

Best, Julian

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.