The new Excel Writer, available starting with KNIME 4.3.0, creates Sharepoint/OneDrive Excel files that can't be opened

The new Excel Writer is available as a part of KNIME 4.3.0. When I try it with these nodes to create OneDrive Excel files:

Microsoft Authentication
SharePoint Online Connector

I would be able to create an Excel file straight into OneDrive just like with the old & deprecated Excel Writer node. However, when I try to open the recently created Excel file, I will get an error: Couldn’t open the workbook.

To workaround the issue, I can use Excel Writer (deprecated), but it’s no longer listed under KNIME > Node Repository

I hope this issue can be resolved soon. To narrow down the KNIME version and platform: I’m using KNIME 4.3.0 on macOS Catalina 10.15.7.



1 Like

Hi Adrian,

thanks for reporting this! I was able to reproduce and we are looking into it. We’ll let you know once there are news.




we were able to find the root cause of the problem and already fixed it. Please excuse the inconveniences and thanks a lot for reporting the bug.

We also found that google drive shows the same issue.

As for now there are two “work-arounds”. Write xls files or use the deprecated Excel Writer (XLS) or XLS Sheet Appender.

Anyway note that the Excel reader is able to read those files!



Thanks @Mark_Ortmann and @SimonS for reproducing and fixing the bug!

I’ll use one of the work-arounds for now and stay tuned for a KNIME update that will contain the fix.


A post was split to a new topic: Option to open file after Excel Writer execution

fyi with 4.3.1 the problem should be fixed. Would be nice if you could confirm that this is indeed the case :slight_smile:



Hi @Mark_Ortmann,

Thanks for the reminder to check out the new Excel Writer on 4.3.1.

I just tested it and confirm that this problem is fixed! Thanks again!!

With 4.3.1 though, it seems like there is another issue with Excel: Sharepoint Online Connector + Excel Reader sporadically would fail with error message: Execute failed: Error during http request. I created a topic for this.

1 Like

Hi atiorile,
thanks for confirming that the problem is solved. With KNIME 4.3.1 we also updated the Microsoft Sharepoint library because of another issue. We will investigate the http request problems further to see if there is a problem with the new library version.