Execute failed: Too few data elements

Hi!

I run write papaer workflow:Taming the Internet of Things with KNIME,below error information printed:

ERROR     File Reader                        Execute failed: Too few data elements (line: 2 (Row0), source: 'file:/F:/快盘/BI/knime/Taming%20the%20Internet%20of%20Things%20with%20KNIME/Raw%20Data/Format2012/workflowset.meta') 

 

I would guess that the file being read is a different format to the first iteration of the loop?

If  your comments are true, could you please let me know how to fix it?

 

I am also receiving this error. Will continue to try to fix, but any help would be appreciated.

I would suggest trying to set the "short line" option in File Reader advanced option. If this doesn't help, I would replace the File Reader with the CSV Reader (using a strange column delimiter!) and later split the rows after all the data is concatenated.
 

6 Likes

Looks like that did the trick. Thanks for the help!

How to check the short line option? It suggests different options (url, location, …)?

I was getting this error using the CSV Reader node, and selecting the “Support Short Lines” option in the Settings tab resolved it, thanks for the tip!

1 Like

The same thing happened to me and selecting this option everything worked perfectly. Thank you!!!

1 Like