Execute failed: Too many data elements

Hello,

   I'm a new user of Knime, awesome tool by the way, and I'm facing a problem that I'm sure that should have an easy solution. With a File reader, I'm reading a big file with columns delimited by "space", but there are some entries with fields like this "1 1 2 3" (with spaces between numbers) aborting the process.

For example:

this would be one line with 5 fields

"70.101 - 14885443  [05/Jul/2015:00:17:10 +0200]"

and this is one of the line that brokes the import ("* * * *" must be read as 1 field) and should be 5 fields too:

"3.243 - * * * *  [04/Jul/2015:00:18:10 +0200]"

Is there any solution to avoid this error without modifying the source file searching and replacing the pattern?

Thank You.

Regards,

Yes, there is the option Allow short lines under Advanced... -> Short Lines

However, than the short line will be written into the first cells.

Hi Iris,

   Thank you for your answer but it is just the opposite situation.

I mean, the line is not too short, it is too long. anyway I have this option checked because there are other short lines that I should accept.

is there another option?

Thank you.

regards.

Oh, sorry.

The other way (or aktually both ways) can also be done as follows:

Use a line reader -> Cell Splitter -> Column Auto Type Cast

You would need three nodes, but you can be more flexibel. e.g. you could also use two cell splitter. The first for the date/time "cut-off" at the end and the second one for the beginning, where something might be missing.

Best, Iris

Thank you Iris, with Line reader I could manage the issue.

Thanks!

Thanks too, this worked well for my usage.