Executing workflow1 from workflow2

I have workflow1 that gets some data and adds the current timestamp as a single row during execution. I create another workflow (workflow2) that takes output of workflow 1 and keeps appending the rows and saves it to a table file via table writer.

Each execution of workflow2 calls the table via table reader appends the row from workflow1 and saves it.
I would expect that the timestamps would change every time I execute workflow2, since it is supposed to call workflow 1 and assign the current timestamp. (i tested executing every minute or so).

Workflow1 take about a 30 seconds to execute so it takes a while, however every time I execute workflow2 it occurs instantaneously. It just seems to take the last stored data from workflow1 and append to the table. When i manually executed workflow1, it then took the new timstamp.
Could someone point out what I am dong wrong?




Hi @thentangler

When you save workflow 1 is everything already executed? Can you reset the entire workflow, save it, then try?



Can you share both workflows?

I’m not sure I see why there needs to be 2 workflows.

In any case, if you want a timestamp when you run workflow 2, one approach would be to move the Create Date&Time Range node to workflow 2, connected to a Container Input (Table) node, and then connected to the Call Workflow (Table Based) node.


In workflow 1, you’d replace the Create Date&Time Range node with a Container Input (Table) node.


Every time I run both nodes in workflow 2, the accurate timestamp gets sent to workflow 1, run through the workflow, and then transported back to workflow 2.

Hi @wkhan ,
I did try to save it in a resetted state and then try workflow 2, but same result.

Hi @elsamuel ,
The issue isnt about getting the latest timestamp, (i was just using that to validate execution), I actually need workflow 1 to execute because I need new data extracted.
The method you described just inputs the latest timestamp from workflow 2 into the column appender. However it still does not execute workflow 1.

In my simple test system, workflow 1 gets executed when I execute workflow 2.

It would be easier to troubleshoot if you shared your workflows.

Can you put both of these workflow in the root of the Local workspace and run workflow 2. After, refresh the local workspace and if an Hello_world.xlsx exists then it worked.

Workflow 2.knwf (4.7 KB)
Workflow 1.knar.knwf (9.8 KB)


Thank you this worked!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.