Execution failed in Try-Catch block: HTTP 400 Bad Request

I’m trying to run the workflow from the HUB examples in the Analytics Platform, in 50. Applications > 36. Guided_Analytics_for_ML_Automation. I uploaded the whole folder of Guided_Analytics_for_ML_Automation to the server and am trying to execute the workflow in the WebPortal. It executes until the view page that asks to select the Execution Settings (where to execute the workflow). There, after selecting Local execution, I press next and the execution stops with the errors:

Call Workflow (Table Based) 7:677:358:224 Execution failed in Try-Catch block: HTTP 400 Bad Request
Call Workflow (Table Based) 7:677:397:397:381:0:224 Execution failed in Try-Catch block: HTTP 400 Bad Request

Do you know what could be causing these errors?

Hello @TomasCardoso,

That is a weird error. Does the workflow group you have uploaded has the same structure as the one in the HUB examples? It sounds like the other (helper) workflows are not found. The helper workflows are the ones in the “Models”, “Prediction” and “Templates” sub-directories. The workflow “01_Guided_Analytics_for_ML_Automation” must be at exactly the location of the workflow group as seen in the image below.


I hope this already solves the problem. Otherwise, let me know.


I have uploaded the whole folder yes, though I’ve noticed that the Templates folder doesn’t appear in the web portal, even though it is on the server in the Analytics Platform.

Another weird thing is: There was one time, and one time only, that when I got to the error, I clicked back to the page where I can select the execution settings and all 4 options that I can pick from where available for clicking (normally just the top 2 are) and when I clicked local execution once more and pressed next, the workflow was successful… But that happened just that one time which is very weird. Every other time I get those errors I mentioned.

Hi @TomasCardoso,

It is expected that the template folder won’t be shown on the WebPortal, since it only contains templates, i.e., there is nothing in there that you can actively use on the WebPortal.

Regarding the other error, it would help if we could have a look at your log files. I’l quick send you a pm, so you can send them in the reply. To make it easier to narrow down the issue, please try to run the workflow again.

You can download the logs from the WebPortal, while logged in as administrator. It’s enough if you only send the logs from today.


Hi @TomasCardoso,

someone reported a similar problem in this forum post and found a solution, could you have a look and see if that fix also works for you?

Tobias U.

yeah I managed to find a solution as well, he’s actually my colleague, we’re working on this together