Executor does not use python environment configuration via exectutor.epf

I have a simple KNIME server setup with one local executor. I followed KNIME Server Administration Guide and exported the local working python configuration, extracted the relevant:


add added these lines to /opt/knime/workflow_repository/config/client-profiles/executor/executor.epf. Then, I also restarted the knime-server and knime-executor processes (I do not know if this is really necessary).

But I still get the following error if I execute a workflow from the webportal:

ERROR Python Script 5:208:0:238: Execute failed: Could not start Python kernel. Error during Python installation test: Could not start Python executable at the given location (no_conda_environment_selected/bin/python): Cannot run program "no_conda_environment_selected/bin/python": error=2, No such file or directory 

So, it seems that /opt/knime/workflow_repository/config/client-profiles/executor/executor.epf is not read.

Do you have an idea? Is there a possibility to some the used properties?

I first used “Setting the preferences in the service (preferred way)” in KNIME Server Administration Guide that did not work. The other way “Setting the preferences in the knime.ini file” does work.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.