Executor Preference changes failing on 4.13


I am really struggling with changing the KNIME Preferences for Executors in 4.13 (single node install).

I have followed the instructions here in order to change the ‘home’ directory for R Interactive Stats Directory: -


I inserted the following to C:\knime_server\workflow_repository\config\client-profiles\executor.epf

/instance/org.knime.ext.r.bin/knime.r.home=C:\Program Files\R\R-4.1.1

I also inserted the following to C:\knime_server\knime_executor\knime.ini :-


However, even after restarting the Windows Service, the R Node (R Source (Table)) workflow - when run on the server - fails to pick up the new directory or the R packages installed to that directory. I get the same error message as before - suggesting the default R home location is selected.

Am I missing something here? How can I check what preferences are picked up by the Server?


The directive ‘-profileList executor’ tells the executor to get the client-profiles\executor directory from the server via REST call, then it combines all pulled profiles into a single combined-preferences.epf, which it then uses.
It isn’t working now because it can’t find the client-profiles\executor directory, because it doesn’t exist.

Move your file

Then restart the executor to make it pull the profileList again, and it should work.


Hi @NDekay,

Thanks so much for responding to my issue! After going through the Administration document for about the sixth time, I finally realised that I had made a stupid error. The section on setting the preferences in the knime.ini file has a split sentence, separated by the code snippet that required insertion. The sentence goes on to say ‘before the line containing -vmargs’. I had failed to notice this on multiple reads. After adding the snippet to the correct position, the server was able to find the preferences and started to pick up the new R Home location. Many thanks for your assistance though on this - appreciate it!


Good find. Not only do the client-profiles have to be in the right place, the knime.ini directives also have to be in the right place as well. :slight_smile:

I’m glad you got it working - nice work!


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.