executor.requirements for a workflow works ?

Hi all,

We’re using Knime Server 4.11.3 and try to set executor.requirements on a particular workflow.
According to the document, we expect a normal execution if we have enough resource for the job, if not, the job will not start.
However, if we set this property for a job, this job won’t start at all regarless the state of resource.

Can someone tell us how to make this setting work properly ? Or we misunderstood the using of this property ?

Thanks in advanced.

Best regards,

Thanh Thanh

Hi ttpham,

Have you also set the configuration in the knime.ini of the executor and restarted the executor? As described here: https://docs.knime.com/2020-12/server_admin_guide/index.html#setting-executor-resources

Best wishes,

1 Like

Hi Ana,

Thanks for your reply.
I set -Dcom.knime.enterprise.executor.resources config in knime.ini but not work either.
Maybe I did not put the right values ?
I want to set up minimum 15GB RAM on a worklfow. So I configure :

  1. In knime.ini : -Dcom.knime.enterprise.executor.resources=48GB-RAM
  2. For the workflow: 15GB-RAM for the executor.requirements.

Is this correct?

Many thanks and Best regards,

Thanh Thanh

Hi @tttpham

Could you try the same value for the executor and the knime-ini? For instance, run the workflow with 48GB-RAM tag?

Best wishes

Hi Ana @ana_ved ,

If I set the same value 48GB-RAM, it works. However, this is not what I really want in fact.

What I want is described in Setting CPU and RAM requirements property for a workflow .
So I re-test with the correct value : ram=15gb , etc.

The workflow is executed, but this time, the workflow is executed even if I set a bigger value than the available RAM.

I misunderstood the usage ?

Thanks in advanced,

Thanh Thanh

Hi @tttpham

Yes, now I got it. Yes, you indeed got to the correct configuration! About your next question: have you set up the corresponding settings also in the KNIME Server Configuration file? If not this is not set, the workflow property values will be ignored:

In case no CPU or RAM requirement has been set for the workflow the default values com.knime.server.job.default_cpu_requirement and com.knime.server.job.default_ram_requirement defined in the KNIME Server configuration file are used. If both default values are either not set at all or set to 0 the CPU and RAM requirements of workflows are ignored.