Exit Code 2 in batch mode


I try to run my workflow in batch mode, but I get a security error message from java.

C:\progs\knime_4.7.0>knime.exe -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowFile=Geraeteverechnung.knwf test.pdf

How do I fix it?

Edit: full paths do not help.

I found out, that my free open source version does not support batch report file generation. Is that true?

i am not aware of any restrictions. Where did you get this information?

Exit code 2 means that the parameters are not correct.

Your test.pdf at the end looks out of place to me, it’s seems like a loose statement. What’s the purpose of this?

If it’s an output name you would like give to some output in your actual workflow, I’d say you have it parse it as variable:


With console log command, i get the Message command not found reportFile

Tomorrow I van upload more infos

I want to create the report with batch.
There is no option reportFile like I found somewhere here in the forum.
How do I manage to create report-file from batch?

(with the table to PDF I’m able to do it, but it is not the first choice)

It is the only option I can think of. You trigger your flow via batch and the flow itself writes the pdf with (as you said) table to pdf

Its possible to customize the Report behind the table to PDF node?

That might depend on what exactly you want to customize. Have a look at the birt nodes. They might give you what you are looking for

Where are the birt nodes? In my repo not.

These are extensions which you need to install first I guess

Hi @hevilp -

Click on KNIME Report Designer to access the extension on the Community Hub. Then you can drag-and-drop the yellow icon you see there into a workflow to install the extension locally. Restart KNIME and the nodes should then be available.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.