Export knime workflow 4.7 does not work

Hi everybody,
in knime 4.7 the “Export knime workflow” does not work: when I click in the menu nothing happens. If I right-click on the tab, the export knime do not appears.
Can somebody help me?


Hi @FabioBusca ,
could you, please, provide a screenshot of what you observe, indicating which tab you click?

1 Like

Hi Daria,
thanks for the help.
When I try as shown below nothing happens

I tried also this way (right botton on the tab)

but the ‘export’ option does not appear.
Note that 2 days ago everything worked well, but only for one day with any clear motivation…

I see @FabioBusca !
Regarding the first screenshot, I could not replicate the same error so couple of questions:

  • which version of KNIME 4.7 do you have?
  • could you try please to select the WF you want to export in the KNIME Explorer and right click on it there? Does the export work?

The second screenshot is all right. There is no option to export a WF by clicking on the tab. This can be done via the KNIME Explorer.

Looking forward to hear from you.

1 Like

Hi @FabioBusca , can you show a screenshot of your entire KNIME application. Sounds crazy I know but this happened to me a few months ago. There was something very specific that I had showing/open (maybe a particular view/window in the perspective) but I cannot remember what it was!! :frowning: If I saw the whole application screenshot it might jog my memory.

One option though that might fix it is to “Reset Perspective”


@darspir , just so you know it is something odd and very specific, so I’m not surprised that neither you nor I can now replicate it.

1 Like

Hi guys,
thanks everybody. I believe that it is difficult to replicate, it happens so randomly…
Any way: i’m using 4.7.3. I am trying to export right now as @darspir suggests (right click in the right position) and it works! Thanks!!
@takbb: i am not sure to do the right screenshot you need, so I put a couple

This is specific of one of my WF

and this the the welcome page

1 Like

Hi @FabioBusca,

I have a few questions:

1- Can you export the workflow from “File > Export KNIME Workflow…” after selecting the workflow in KNIME Explorer without any issues?

2- After you selected “Export KNIME Workflow…” and nothing happened, was KNIME workbench still responsive?

In case you could replicate the issue, could you check these:

  • if KNIME workbench is responsive after clicking on export KNIME workflow…
  • if the workflow is selected in KNIME Explorer (if not, what is selected)
  • if there are any open dialogs, windows, views, etc.

Thank you!

1 Like

Hi @armingrudd,
going in order:
1 - i just tried and now everything works well: I can select any WF, I can choose any location ecc. When it did not work the dialog window did not appear, but was the only fault I experienced
2 - I confirm that evething else (a part the export) was always ok

I hope I gave you the needed infos. Otherwise do not hesitate in contacting me


1 Like

Hi @FabioBusca, was it working ok at the time you posted the previous screenshots?

If so, next time it doesn’t work (if it stops working) please post a screenshot of your entire work KNIME application at the time when it isn’t working. (Obviously feel free to scribble over any wording within workflows etc or anything that may be sensitive.). I’ve been trying out all sorts of things but I am struggling to remember what it was that I found “caused” the problem. By the way, do you ever use the “search” box at the top of KNIME explorer?

I know that there have been just a handful of reports of this on the forum over the past few years but nobody has been able to replicate it. It seems to be quite rare! Maybe there should be a forum badge for “survivors” of this one! :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.