Extremely slow startup after proxy settings..


I am encountering a performance issue after setting up the manual proxy settings. KNIME 4.5.1 takes approximately 6-7 minutes to start!! I thought that there is some issue with extensions thus removed a ~dozen of the extensions but the issue did not resolve. I also removed all the startup plugins from preferences but I still faced the issue. At the end I just removed my proxy settings and then it booted like normally it does i.e. ~1 minute. Is this a bug ? Can some one please check.


Hello @mateenraj,

How did you setup the proxy connection on KNIME Analytics Platform 4.5.1?

I am asking this as KNIME checks for updates at the beginning, trying to reach all configured update sites. If this connection is blocked by the proxy or a firewall the serial requests might run into a timeout each, so that the startup time is prolonged.

Maybe it helps already if you uncheck File → Preferences → Install/Update → Automatic Updates → Automatically find new updates and notify me

Could you please check this?


1 Like

Hello @MichaelRespondek,

Thanks for your reply. Actually I have done various things to figure out the problem and it costs me sometime. Let me briefly summarized those for others:

  • To make it faster, I removed few extensions and then the REST API nodes seems stopped working any more, they were always showing me error 407 even though I have given the credentials
  • I put my credentials in KNIME.INI but that also didn’t solve the problem
  • I uninstalled / reinstalled KNIME 4.5.1 but got the same authentication 407 error after I provided the credentials in Manual proxy settings. At this stage, I literally got annoyed
  • I installed 4.5.0 but still faced the same issue i.e. 407 error.
  • I deleted KNIME entries from Registry, deleted files from hidden local folders (meta etc) and Installed the KNIME folder on a Temp directory (as I don’t have Admin rights on my machine all the time) but it didn’t resolve the problem
  • Giving thoughts about the issue, I thought that there might be some extensions which are needed for the execution of REST API nodes to work so I installed some extensions (by removing my credentials) and viola, the workflow worked
  • It is also interesting that when I give credentials, I can’t update KNIME + install extension but REST API nodes work and on the other hand if I remove credentials (use Direct without credentials), KNIME can install updates and extensions
  • I also try to change my LAN settings in Internal Explorer (the old classic way) but that also didn’t solve the problem
  • Now KNIME is taking the same long time but I am happy that it is WORKING!

To answer your question, all automatic Updates are disabled as well as the startup options but it still takes long.


Hello Mateen,

Thank you for providing the summary of the steps you tried and the raised errors.
The 407 error indicates that the proxy was reached but is missing proper credentials to authenticate. This should work with “Manual” selected as the active provider with credential setup.

What you need to figure out is, which sites are needed to use the proxy and which should bypass the proxy. At least the KNIME Update sites seem to work without the proxy settings. on the “Manual” Active Provider Proxy settings you can add *.knime.com to the proxy bypass list and it will handle all calls to this domain as if set to “Direct” access.

This setup should be working with the REST nodes and the update/install functionality of the KNIME Analytics Platform.


Hi Michael,

Unfortunately with “Manual” it didn’t work for me normally (attached). I will try to add KNIME address and report if the KNIME starts with the “normal” time.


Hi Mateen,

Were you able to check, if adding the KNIIME Server to the Proxy Bypass List solves your issue? Is it working now?


Hi @MichaelRespondek

I tried it but then often it didn’t boot up at all (showing no responses). Once I removed the Bypass settings, it started booting with delays. I changed various things / uninstalled + installed few times but nothing worked for me. Now I have accepted the time it takes to bootup (7-8 minutes). Some screenshots are attached. The progress bar shows where it takes most of the time (now I have much less extensions but it still takes the same time).



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.