Failed to connect to Oracle Database 12c.

Does anyone have luck getting KNIME to work with Oracle DB 12c? I need some help in here.

I installed an Oracle DB and downloaded ojdbc7.jar from the following location:

I added the driver to Knime under Preferences->KNIME->Databases

I added a Database Reader node and configured it with the following information:

Database Driver: oracle.jdbc.driver.OracleDriver

Database URL: jdbc:oracle:thin:@localhost:1521:orl

User Name: scott

Password: tiger

SQL Statement: select banner from v$version

I clicked on "Fetch Metadata" and got the following error:

Error during fetching metadata from database, reason: IO Error: The Network Adapter could not establish the connection

I executed the note and got a similar error:

Execute failed: java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection

I suspected it was the format of the connect string. But then I tried it in a standalone java program using the same ojdbc7.jar in the classpath and it worked.

The java program:

import java.sql.*;
class OracleCon{
public static void main(String args[]){

    Connection con=DriverManager.getConnection("jdbc:oracle:thin:@localhost:1521:orcl","scott","tiger");

    Statement stmt=con.createStatement();

    ResultSet rs=stmt.executeQuery("select banner from v$version");


      }catch(Exception e){ System.out.println(e);}


The output:

$ java -cp ".;./ojdbc7.jar" OracleCon
Oracle Database 12c Enterprise Edition Release - 64bit Production
PL/SQL Release - Production
CORE      Production
TNS for Linux: Version - Production
NLSRTL Version - Production

I wonder why this is not working in KNIME with the same connect string. Please kindly suggest how I can debug this further. Thanks in advance.







Double post, please see here: