Feature request: Copy paste optimization

Hi,

I have a suggestion for pasting new nodes into a workflow:

It should paste the nodes around the mouse arrow or in the center of the current view, instead of using almost the old coordinates. As it is done now, the nodes may be inserted 'far away' from the point where they should be and you have to drag and drop them over the whole workflow.

 

best regards

Soren

6 Likes

I second this! It's also annyoing when collapsing nodes into a metanode - seems like the same cause for a different effect.

In the meantime, a workaround is to paste via right-clicking, which resets the coords to the mouse pointer's.

Cheers
E

I third this.

It would be even better if you can copy a node, click on another node, and paste the copied node directly as a child of the selected node with the link in place. Ofcourse works only well for nodes that have one output, but most nodes fall into that category.

I totally agree with you. :)

Thanks

Regards

bump! Needs to happen!

I know there is a ticket for this in the system already, but I can’t immediately find it. When I do, I can add a +1 from you. In the meantime, as mentioned above, one workaround for this is to right-click and use Paste from the context menu instead of using a keyboard shortcut.

Sorry for the trouble.

4 Likes

Internal reference: AP-2168
Br,
Ivan

1 Like

I’m gonna latch onto here. I’ve mentioned this somewhere else already but what would be very good is actually to be able to copy&paste between different knime instances.

This is for multiple reasons one of them being I can connect via remote desktop to a more powerful machine than my laptop which can be used for longer running workflows. Sometimes it would be extremely handy to copy over some nodes from knime instance on laptop to knime instance on the more powerful machine. This is not possible at all an one need to export the whole workflow, copy&paste that and then import it.

Same is actually true for 2 knime instances on same machine. No copy&paste possible between them. Why would you have 2 instances? One that matches the knime server version (which usually lags behind) and one instance to have all the new features.

Copy&paste between KNIME instances would be extremely helpful for my specific use-case.

3 Likes

Hi there @beginner,

makes sense. Will add it to existing ticket and let’s see.

Br,
Ivan

Has this ever been fully addressed? The right-click workaround is good for now (six years :sunglasses:), but it seems a constant headache.

Hello @scapuzzi,

nop. Have given another +1 to it.

Br,
Ivan

2 Likes

This drives me nuts. Please address this one! Ha

2 Likes

Request noted @ben_westphal.
Br,
Ivan

2 Likes

+1 from here. It would also be good if you could drag a node and hold ctrl while dragging to create a copy

1 Like

Hello @mmcmcmc,

request and idea noted :wink:

Br,
Ivan

2 Likes

I was at least able to do a workaround via triggering a macro (left click, Shift-F10, p) with one of my controllers, but add me as a +1 as well. It is very confusing when zoomed in on very large workflows when I slip up and do a standard Control-C paste via mouse shortcut / muscle memory.

This is a good suggestion, especially Ellert’s suggestion of pasting right next to a selected node. Doesn’t necessarily have to auto-connect.

+1 from me :evergreen_tree:

1 Like

I was also able to figure out triggering this right click paste macro via a single hotkey command from my mouse. I used JitBit Macro Recorder, which includes a “Hotkey Macro Launcher” so that you can trigger macros via a single keyboard command. Here is the macro if anyone is interested. Not freeware, but the basic version might be worth it if you also use it elsewhere to eek out more productivity.

Mouse : 0 : 0 : Click : 0 : 1 : 0
DELAY : 100
Keyboard : ShiftLeft : KeyDown
DELAY : 50
Keyboard : F10 : KeyPress
DELAY : 50
Keyboard : ShiftLeft : KeyUp
DELAY : 100
Keyboard : P : KeyPress

Then you save the Macro, go to Tools / Bind Macros to Hotkeys, point to the Macro file and set your hotkey. Make sure you go to settings in Macro Hotkey Launcher and select “Run at startup” as well.