File Reader Node - "Data row has too few data elements node" error

As the screenshot shows, I am having trouble loading a new dataset into my existing workflow in Knime. The file reader node keeps throwing me a “Data row has too few data elements node” error.

Would anyone know how to remedy this problem?

If you could share the file with us (preferably as file, not as screenshot) that would help finding the cause. Don’t do that if the data is sensitive though.

I’ll try to guess the issue in the meantime:

  • The preview looks weird. Try to use different encodings in the Encoding tab (start with UTF-8).
  • The error message means that at least one row (including the very first row used for the column names) does not have enough values to fill all cells. Maybe the default column delimiter is wrong? You could also try µ (or any other character that doesn’t show up in the file).
  • The preview shows only one row. Try to set a different row delimiter (Windows uses \r\n, Unix uses \n)
  • any combination of the above
  • try the “Autodetect format” button
1 Like

There should be an option to "support short data rows in the file reader settings
br

I was looking for that in the advanced settings and obviously didn’t find it there. Would have mentioned it otherwise. :sweat_smile:
Thanks for pointing it out!

1 Like

Ah it seems saving it as a CSV with UTF-8 encoding seemed to work, thanks alot

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.