File Store Cells Error


We have a scheduled workflow that daily invokes another remote workflow in order to get a PDF (BIRT) report, and then sends an email with several attachments, included this PDF.

After updating our KNIME server to v4.10.1 now we have problems when we try to create any workflow with similar behavior (send a BIRT generated PDF). We get these errors:

We also have tried to create and execute on Server AN IDENTICAL WORKFLOW to which is still working perfectly every day. We got the same error. So, what has been changed on the server? Why is this not working properly?

Some additional info: these workflows (all of them, the old one and any new similar ones) work perfectly on local KAP.

Hello @jricgar,

the error message in the table only indicates that the respective data cell containing binary data can’t be displayed in the remote workflow editor (aka job view). There is no problem with the underlying workflow on the server. It’s just that the data required to show a preview in the table isn’t transferred from the server to the client because it’s not supported, yet.

The reason it used to work is because your report files (and therewith the binary data cell representing the report) obviously increased to a size where KNIME uses a different data cell implementation in the background (which is internally called ‘FileStoreCell’). And the preview of ‘FileStoreCells’ in the remote workflow editor is not supported, yet.

The error message needs to be improved to be more self-explanatory - I’ll put it on our list.