Force "IUPAC to RDKit" to use newer OPSIN library?

I notice that the “IUPAC to RDKit” node seems to be out of date with respect to the current version of the OPSIN library. I base this on the observation that online OPSIN tool can convert the following names, while the node cannot. Is there a way to get the node to use the most recent version of the OPSIN library? I can download the most recent OPSIN jars, but I’m not sure where I should put them. Any thoughts?

bis(diphenylphosphino)ferrocene palladium dichloride
1,1’-Bis(Diphenylphosphino)ferrocene-palladium dichloride
1,1’-Bis(Diphenylphosphino)ferrocene-palladium(II) dichloride

Hi @joshuahoran,

Wow, you’re right, the version we’re using is very out of date.

Unfortunately I don’t think it’s that easy for you to update. The RDKit KNIME nodes use a version of the opsin jar which include the version number, so you can’t just replace it.

I will update the version used within the nodes and will update the nightly builds once I’ve got this problem figured out: Nitrate salt incorrectly(?) connected to compound in opsin 2.5.0 · Issue #142 · dan2097/opsin · GitHub

-greg

1 Like

FYI: The nightly builds of the RDKit extensions now include opsin v2.5.0.

1 Like