from BigQuery How to increase the timeout value?

Hi,
I have connected Knime to BigQuery and I have one table for each day unfortunately. SO I have used the db query node:
select * from analytics_223280726 .events_2021* in order to keep all data from 2021, but I have this error:

Execute failed: [Simba]BigQueryJDBCDriver The job has timed out on the server. Try increasing the timeout value.

How can I increment the timeout? I think data are too much but I need all of them…

Thanks

Hi @giad ,

Please try adding the following to the end of your connection string for BigQuery:

jdbc:bigquery://...;Timeout=3600;

and increase the timeout to a larger number if you find you are still getting this error.

If this does not fix the issue please let us know and we can try other solutions.

Please note the parameter is case sensitive.

Thanks,
Zack

2 Likes

Hi!
Thanks
But where Can I increase the timeout?

image

Hi @giad ,

You can input additional parameters in the JDBC Parameters tab. They will ultimately be added to the connection string.

Thanks,
Zack

Hi,
someone can show me with a screenshot what and where is needed adding the string
`jdbc:bigquery://…;Timeout=3600;" ?

Thanks

Ale

Hello @Ala,

and welcome to KNIME Community!

In case you haven’t figured out it yet you can add timeout as parameter in the JDBC Parameters tab of connector node. See here for more:
https://docs.knime.com/latest/db_extension_guide/index.html#jdbc_parameter

Additionally in above linked document you can find more info about Database extension together with example on how to connect to BigQuery in Examples section.

Br,
Ivan

1 Like

For everyone that has the same issue, please find below the right screenshot “how to add the Timeout Value”

timeout

I share also this helpful source:

Best

Ala

3 Likes

Hello @Ala,

glad you made it and tnx for sharing your solution with adding timeout parameter JDBC URL template upon registration. Nice one :+1:

Br,
Ivan

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.