FTP Connector can not work in the Business Hub

Hello everyone.

We are using FTP Connector to access local files(Input Excel files, Config files etc) from Business Hub, but FTP Connection seems no available in the Business Hub :

there is error in the “List File/Folders” node:


※ The FTP Connector works well in the Analytical platform 4.7

How to solve the problem?
Thanks in advance.
Ryu

Did you upload the FTP Connector node in executed state? This would explain the warnings and errors you are seeing. The node must be freshly executed otherwise there will be no usable connection downstream.

Hello @thor

Thanks for the prompt answer.

The following is the opened workflow in the Business Hub, it seems FTP Connector is not in executed state:

I execute the workflow with reset before execution.

Thanks
Best,
Ryu

Hello Ryu,

One of your screenshots is showing Container Input (Table) and Output (Table) nodes. This is usually an indication, that this workflow is called from external, e.g. a caller workflow.

If the workflow would be called in a partly executed state you would run into these issues while executing the caller workflow with the “Reset before Execution” enabled option would not influence the called workflow.

Could you try to reset the specific failing workflow and upload it to the hub again?

In addition: Could you elaborate on the location of the ftp server you are trying to access? If you have the Remote Workflow Editor (RWE) installed as part of your executor image and locally on the Analytics Platform, could you please check the failed job which nodes failed and the additional error messages?

Thanks in advance,
Michael

Hello @MichaelRespondek

Thank you for your answer.

I just want to test the above workflow, so I do not run the caller workflow and run the above workflow directly with the “Reset before Execution” enabled option.
※ the caller workflow also call another workflow which is KNIME Server version and not fixed for Business Hub version. So I just run the above workflow directly.

I try to reset the specific failing workflow and upload it to the hub again, but the workflow failed with same error message.

The System architecture which shows the location of the ftp server :

I do not have Remote Workflow Editor (RWE) installed, I right click failed job and click “save as workflow” to export it, and find it stop in the “List Files/Folders” node and with the warning “No connection available”:

I right click failed job and click “show workflow messages” and find the error in the “List Files/Folders” node:

FTP Connector Setting:

Right click FTP Connector in the failed job to check fs_specifier:

Best,
Ryu

Hi Ryu,

I have to check KNIME-internally what could have caused this error. I will keep you updated on our findings.

Thanks,
Michael

1 Like

Hello @MichaelRespondek

My Business Hub and FTP Server are running in the same AWS EC2 instance.
After I change FTP Host setting in the FTP Connector from private IP address(local network IP address) to public IP address(Internet IP address), the problem is solved.
But why must FTP Connector in the Business Hub Workflow use public IP address(Internet IP address) to connect FTP Host ,when they are in the same machine?

Best,
Ryu

1 Like

This is likely caused by the internal network policies which prevent executors accessing arbitrary internal services for security reasons.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.