FTP Connector Issue

I am running 4.7.7, and have been trying to use the FTP connector node.

When I provide my credentials, I do appear to log in, but am not able to select any directories (this appears to be similar to an older bug).

In addition, the file connection does not appear on any nodes that are connected through the system connection.

I have been using the legacy node without any problems, but it doesn’t seem to play as well with Knime Server. (I can’t figure out to use Knime Server as the host for uploads)

Legacy works:

New Connector doesn’t work:

Thanks for any help!

Hi @npatrick,

Could you please try to adjust the “Maximum FTP connections” to 1 on the “Advanced” tab of the new connector node? There are some FTP server who does not allow or limit the number of parallel connections.

This “Advanced” tab includes also other useful options like timeouts and FTPS settings.



@MichaelRespondek that worked! Thanks so much!

Usually my method of fixing something is flipping various switches until it works, but I didn’t think to change this one! :slight_smile:

Happy to hear that this change in configuration solved your issue. Thank you for the feedback! :+1:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.