General Extension Problem

Hey Guys,
recently i needed to reinstall KNIME because of some errors.
After the reinstall all my extension were gone and i could not find them in the repository.
So i wanted to reinstall all the extensions, which wasn´t possible.
The error message was “extension already installed”.
So i checked the installation details and every extension shows up there as “installed”.
Problem is i can not deinstall them nor install them and i can not use them.
Do you experienced something like that?
Is there a folder with the extensions which i could delete to fix this?

thanks in advance!!

Hi Moritz,
that’s a strange error. Why can’t you uninstall the extensions from the Installation Details dialog? Is there an error or does the uninstall button simply nothing when clicked?
Kind regards

Hey Alexander,
the uninstall button is greyed out.

That’s strange. Can you check whether the plugins are physically there? They should be in the KNIME installation folder under Eclipse/plugins. If you are on macOS you need to open That folder should be full of jar files. Also worthwhile to check is the folder Eclipse/features. Could you tell me what you find there?
Kind regards

1 Like


have you tried starting KNIME using the -clean option in knime.ini (don’t forget to remove it afterwards)? This has resolved the problem in some cases for other users.

Otherwise I’d recommend to delete the whole KNIME folder and install everything from scratch.

Btw. were you using KNIME 4.0 before and installed 4.1 now?


1 Like

Tanks for the fast reply!

There are a ton of .jar files in the plugins folder, and given their name that are indeed the extensions. But for example i could not find the ARIMA .jar which i couldn´t deinstall in the screenshot above.

Also in the features folder, there are all extensions given their name of the folder.

I will try it out now!

And not, i installed KNIME 4.0 again.

Thanks for the help guys!


So i tried the -clean approach, but it didn´t help.
In unistalled everything and deleted the folders with the plugins manually.

After the reinstall i could install all plugins as usual!

Thanks for the support!



sorry for your inconveniences!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.