Generate BIRT Report with two master pages

Dear Knimers, I do not know is it bug or not but when if I try to run generated BIRT report using Call Local Workflow, I find out that:

  1. if the report name is not by default naming convention, than I can see only master page template - which is not such a big problem, i mean, you could easily rename this two BIRT report files in default_report.rptconfig and default_report.rptdesign but
  2. the main problem is that if I have more than one master page in my Report design (which I have, two master pages actually) than when I’m using Call Local Workflow I can get only first one visible, not second one - which make my Report not look as I excepted - but when I running my workflow “normally”, I mean when I generate report from BIRT Report Designer tools option and not using Call Local Workflow than everything looks fine, there is no problem with second master page.

Dear krimers, it seems to me that it should be a bug, and I need a help - I made completely new report from the scratch in my workflow with two master pages, one which is portrat orientation and second one in landscape design. When I run report from BIRT Report option “View Report” than everything looks fine and report correctly show first and second master page but when I run the same workflow and genereting report using Call Local Workflow than there is no second master page, only first master page is visible and takes all report desing. I can share this two documents to make difference clear, if needed.

Hey @ssimara,

Could you please share the workflows, that would be a little simpler to see exactly what you are seeing.

Thanks,
Ryan

Hello, thank you for your kind response, for a moment I was starting to think that maybe my question is zero response and would never get an answer :slightly_smiling_face: … so, my original report is too complex and contains confidential information that I can’t share it but I created two simple workflows as simple as possible just to demonstrate the problem … you can find these workflows in KNIME public folder - this is my first time I’m using it, so, tell me if it’s correct example:
WF1 - first workflow
WF2 - second worflow


1 Like

@ssimara,

Hopefully I have found the answer to your question. Within the Call Local Workflow (Row Based) node, there is an option to Create Report (I decided to go with PDF).

It appears that when this node is ran and saved in the executed state, then you can check in the file repository for this workflow and go within the Call Local Workflow node folder → filestore → all the way until you see a document. If you open this the report should look as expected.

Let me know if you can replicate this!
Regards,
Ryan

Hi rsrudd and thanks for your support … I tried to follow your instructions, but there is still two main problems left for me:

  1. first of all, I need that my report be in word docx format, as you promise that within Call Local Workflow (row based) and that they will be an option to Create Report like doc or docx format.
  2. I can not find, following instruction, any map called filestore - Call Local Workflow node folder contain just only one file: settings.xml … I will also sent to you a image of folder structure and also one image of Call Local Workflow node map which, as I already said, contain just one file.

image

image

And sorry, I forget to say that pdf works fine, but I do not need pdf as report result.

Oh, sorry again - I finally find map filestore as your mention, after saving process! but there is still something which I need and I not get it - doc or docx format do not do my reports as I wanted to look like!

From the beginning I forgot to point out that the main thing I noticed as a problem when generating reports with two or more master pages, as far as I know, is the one related exclusively to the selected format: doc or docx (I never tested some any other options) . I apologize for this note which come a little bit too late.

@ssimara, so I have not been able to find a workaround to this problem. I will input a report with our engineers to look into this.

Thanks,
Ryan

Thanks Ryan, looking forward for the solution.