Generic Web Service Client - SOAP request: Error compiling schema from WSDL


I’m trying to use the generic web service client for a SOAP request and it’s complaining about a compiling error?

The WSDL location works fine in SOAP UI.

Open for public: I’m pretty sure this worked fine some months a go. I just don’t remember how I did it. :thinking:

Is there some other way how to run simple a SOAP request, or do I have to switch to Python for this?

Thanks in advance for a reply.

Hi @dr_snglr -

I did a little testing here based on the WSDL file and error message you provided. The problem seems to be in the file here:

If I delete the line with ZUST_AUSB then the node can parse the XML without errors. At first glance, the problem is that the node isn’t differentiating between the lines with “ZUSTAUSB” and “ZUST_AUSB” - it’s somehow not picking up on the underscore character.

Does such a workaround help? Here’s the file: fpre_webservice_edited.xml (267.5 KB)

You can reference it in the node using a path similar to mine: file:///C:/Users/Scott/Desktop/fpre_webservice_edited.xml


Thanks for the fast reply @ScottF.

That did the trick.

Much appreciated.


Also, just so by the way. For anyone who finds this in the future:

I was able to do a SOAP request using the normal POST node, just like a REST service.

You can put the XML as a column in the request body. It’s just picky about encoding, a “Content-Type: application/soap+xml; charset=utf-8” header solved that for me, binary to text to make it readable.

I prefer this, because a lot of variable in the POST service I have to use are optional. The generic web client does not like optional variables.

Noice. :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.