Geospatial Analytics Extension for KNIME 1.1.0 released!

we are happy to announce the release of version 1.1 of the Geospatial Analytics Extension. One major addition of this release is the support for geocoding. In addition, this release adds support for drive time analysis via the new spatial network nodes. This release is only the starting point of this category of nodes, and we will continue to extend this functionality with future releases.

For more information on how to update to the latest version of the Geospatial Extension see the KNIME documentation.

This version works best with KNIME Analytics Platform version 4.7.3.

New nodes

  • Spatial network nodes for drive time analysis e.g., isochrone map, drive time distance matrices​ (OSRM and Google)
  • Geocoding nodes that convert points to addresses and vice versa
  • Various other nodes such as Voronoi (Thiessen) Polygon, Bounding Circle and Extract Metadata such as CRS and geometry type


  • Harmonized distance handling in various nodes that allows users to select the desired distance unit and performs projection if necessary
  • Improved result column handling that allows the user to decide to overwrite the input column with the result or append a new column
  • Support for user selected ID column in Spatial Weights nodes
  • Extended file support allows for reading online GDB and GPKG files as well as support for KML/KMLZ files
  • Spatial Join node with new options “has its center in” and “contains the center of”
  • Support for date & time columns in geospatial view nodes
  • Various node description improvements
  • Library updates of Curl, Fiona, Folium, GeoPandas, PyPROJ, PySAL, Shapely, etc.

Bug fixes

  • Missing value and special character handling in various visualization nodes
  • DataApp compatibility of visualization nodes
  • Fix problem when executed in read-only KNIME installations
  • Fix problem when executed in offline environment

For a detailed changelog click here.


@tobias.koetter on Windows 11 I get this error message:

unfortunaltey, same error message here too. Win 10, downgraded from Win 11.

Hello @mlauber71 and @Awiener ,
can you please check the KNIME log (View->Open KNIME log) to see if you can identify anything that could help to find the root cause of this? With version 1.1.0 the Python dependencies are downloaded and installed via Micromamba and PIP instead of from the KNIME update site which might cause this problem.
Thanks for your help

Hi @mlauber71 and @Awiener,
Could you please help us to gather more insights and paste the output of the following files?




Thanks so much,

1 Like

@carstenhaubold is it possible that the installation does not use a proxy setting while installing? Other installations would have no problem using the defined proxy.


critical libmamba Download error (6) Couldn't resolve host name []
    Could not resolve host:

@mlauber71 that could be, but it would be very unfortunate :confused: I’m afraid that this could be something where libmamba doesn’t behave exactly like conda.

For reference, here are some related discussions

Do you have a proxy configured in your .condarc @mlauber71?


@carstenhaubold I can check all that and hopefully will manage. The point about an extension is that it should work consistently within the KNIME framework. And from what I understand the geo extension should use a Python version encapsulated in knime.

You might have to try to give a proxy to this version from the configuration or add a description how to set up such a proxy as a user.

@mlauber71 thanks, please keep me in the loop, I’m happy to help and make our setup work with proxies because it definitely should!

The point about an extension is that it should work consistently within the KNIME framework. And from what I understand the geo extension should use a Python version encapsulated in knime.

It definitely should work consistently. We have changed the infrastructure under the hood of Python extensions such that (exact versions of) packages are downloaded from conda-forge at installation time instead of us hosting + shipping them because it would just be duplication of binaries. However, we wanted this change to become active with the KNIME AP 5.1 release because then we’ll provide easy means for an offline installation – useful if you are installing the extension on a system without internet connection / firewalls etc.

I’m investigating why this was used for the Geospatial extension in version 1.1, before the feature should actually go live…


Hello @mlauber71 and @Awiener ,

we have just released version 1.1.1 of the Geospatial Extension which includes all Python dependencies and some bug fixes as well as smaller enhancements. In addition to the installation changes we also updated the underlying GeoPandas library to version 0.13.2 that fixes two regressions in the library related to reading geospatial files. The enhancements are around supporting string and long columns as ID column in various nodes. For a detailed list of all fixed bug see the release page.

Thanks for your patience


@tobias.koetter that is great news. Will try. Edit: it does work :slight_smile:


Unfortunately v1.1.1 is still not working for me over company proxy.
Running as admin and installing via the software site returns a “ShellExec command exited non-zero exit value” error.
Running as admin and installing via the .zip returns a “missing dependencies” error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Geospatial Analytics Extension for KNIME (
  Missing requirement: Geospatial Analytics Extension for KNIME ( requires 'org.eclipse.equinox.p2.iu; 4.7.0' but it could not be found

These are the same errors that were returned when attempting to install the previous version.

Hello @al_sweets ,
I’m sorry to hear that. Do you experience similar problems when installing other extensions? Would you be able to send us more details (e.g. stacktrace) of the ShellExec error message? Maybe there is more information in the KNIME log.
Which update site did you download when you installed it via zip?

Hi @tobias.koetter, here’s the error when installing over the network via the software site:

ShellExec command exited non-zero exit value:
session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R], action=org.knime.product.p2.actions.ShellExec).

This is the zip I downloaded:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.