Geospatial Analytics - Lat/Lon to Geometry


I’m trying to convert two columns Latitude and Longitude to geometry using the new node Lat/Lon to Geometry, however, the node is not executed and the following message is shown: Execute failed: construct from string not available yet
Any idea on how to solve this?


Hello @lisandro ,

I tried to do the same and everything seems to work fine.
Have you tried to convert your coordinates into double?



Have a nice day,


Hi @lelloba !

Yes, I’m using double format.
The issue seems to be related to the existence of string data columns with the Lat Lon columns. I tried to remove string data columns and the Lat/Lo to Geometry worked correctly.


1 Like

Hello @lisandro ,
this is unfortunate can you please provide a bit more information about the column(s) that you need to filter to have the node executed successfully. I created a table with two double columns for latitude and longitude and additional string columns and the Lat/Lon to Geometry node executes successfully.

1 Like


I have encountered the same issue. I have a data set with columns for latitude and longitude that are both set to double types. There are also other string, numeric, date, and time columns.

  • When I filter my data set to include only the lat/long columns, it works correctly.
  • When I include all other string columns, it works correctly.
  • When I include other numeric columns, it works correctly.
  • However, when I include either a date or time column, I receive the error mentioned above.

Hello @johnvemery ,
thanks a lot for your help. This is very useful information that helped me to reproduce the problem. We will look into it and report back to you here.


Hi @tobias.koetter !

I’m working with string, integer and double data type columns. My first try was keep only latitude and longitude columns and it worked. After, I tried to add string columns and it worked as well. After that, I added the integer columns and the node failed again. Then I removed string and integer columns, keeping only double columns (including lat and lon) and the node failed again, showing the following message:
Execute failed: java.lang.IllegalStateException: Customization of entry point failed.
With that message I’ve found at Knime Console the following message:
*WARN DefaultPythonGateway Python standard output: *
WARN DefaultPythonGateway Python standard error: Traceback (most recent call last):

  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\org.knime.python3.nodes_4.7.0.v202211291148\src\main\”, line 56, in *
  • import knime.extension.nodes as kn*
  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\org.knime.python3.nodes_4.7.0.v202211291148\src\main\python\knime\”, line 54, in *
  • import knime.api.views as _kv*
  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\org.knime.python3.views_4.7.0.v202211290817\src\main\python\knime\api\”, line 360, in *
  • import matplotlib*
  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\\env\lib\site-packages\”, line 113, in *
  • from . import _api, _version, cbook, _docstring, rcsetup*
  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\\env\lib\site-packages\matplotlib\”, line 27, in *
  • from matplotlib.colors import Colormap, is_color_like*
  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\\env\lib\site-packages\matplotlib\”, line 56, in *
  • from matplotlib import _api, _cm, cbook, scale*
  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\\env\lib\site-packages\matplotlib\”, line 22, in *
  • from matplotlib.ticker import (*
  • File “C:\Users\Lisandro.eclipse\903338280_win32_win32_x86_64\plugins\\env\lib\site-packages\matplotlib\”, line 138, in *
  • from matplotlib import transforms as mtransforms*
  • File “”, line 1007, in _find_and_load*
  • File “”, line 986, in _find_and_load_unlocked*
  • File “”, line 680, in _load_unlocked*
  • File “”, line 846, in exec_module*
  • File “”, line 941, in get_code*
  • File “”, line 1040, in get_data*

When I tried to run the Lat/Lon to Geometry again, Knime stoped working, I got three beeps in my computer, and it stoped working as well. Only solution was to force shutdown…

Hope this information may help.


Hi Tobias,

Just wanted to add that date and time type columns are also not available to use as tooltips or marker popups in the Geospatial view node as well. I had to use them in the string data type format. This node also fails if the date and time columns are included as part of the input table, even though they do not show up as fields that can be used to configure the view.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.