Geospatial nodes - ERROR java.lang.IllegalArgumentException

I have been working with geospatial extension with no problems. However, today for all the geospatial nodes I try to use, the following message appears, when I try to open their configuration window: ERROR java.lang.IllegalArgumentException

Any idea on how to solve it?

Additionally, I tried to reinstall Knime and the Geospatial Extention, and it wasn’t possible, due to the following message:

How can it be fixed?

Hi @lisandro

I have pinged the team internally to look into it.



Hi @lisandro,

The installation error is interesting, I haven’t seen this one before.

To determine whether that is a problem with the way how KNIME calls Python, could you please navigate with a Command line to the env folder containing python.exe and run python.exe and let us know whether that produces the same error or whether that works? That would be very helpful.

I have searched for the error, and people suggest to set PYTHONHOME and PYTHONPATH but usually that should not be needed (django - init_fs_encoding: failed to get the Python codec of the filesystem encoding - Stack Overflow). So I suppose this is not the right solution here.

Are you using Windows 11?


1 Like

Hi @carstenhaubold

I did as you said to run python.exe and it worked correctly. I’m running python scripts within Knime for other purposes and they work correctly, the problem (until now) happens only with geospatial nodes.

I’m using Win 10.

Thank you,

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.