Get request node fails due to proxy settings

#1

Hi, I have a workflow that uses a GET request node to connect to a website and extract info locally. The same workflow works perfectly though Knime Analytics platform, however on Knime Server I get the error “No JSON columns available”

image

If you have a solution to this issue, please help, much appreciated.

Kind regards,
Laura

0 Likes

#2

Hi @despina_l,

can you check the output of the GET Request node? Which response do you get? Can you make sure the API you are calling is accessible from the server machine?

Best,
Marten

0 Likes

#3

Hi Marten,
the output is the Get request node is:

Row0 407 text/html; charset=utf-8 ?

Seems like the proxy settings which are used on Knime server cause this issue. To test the API is accessible - not sure how to do this other than through Knime workflow (this is a company server), and locally from Knime analytics version I have no issue running it and extracting the data.

Krgds,
Laura

0 Likes

#4

Hi @despina_l,

Can you check the proxy settings the executor’s preferences? Are credentials for proxy authentication set properly?

Best,
Marten

0 Likes

#5

Yes, I got the feedback those are correctly setup. Other flows running on the same server can access the internet (e.g. Azure blob, & Amazon connectors, etc) .

Thank you,
Laura

0 Likes

#6

Hi everyone,

Did anyone have the same issue as I do? Perhaps the Get Request node is the issue?

Many thanks,
Laura

0 Likes

#7

Hl, after a job reschedule, the workflow works with no issues.

Thank you Marten for your help & follow up.

Brgds,
Laura

1 Like