Get Request with wrong json response due to Russian symbols - FIXED


I am trying to make a get request (with GET Request node) to google translate api, to translate some russian text into english. Already tried with other languages and works fine, but in russian is not the same!

I've already tried (with java snippet) encoding, charset, and the response is always the same. I will show an example:


For this request:Время%20мин%20перепада%20давления%20в%20холодном%20коридоре%20


Postman response:

            "Time of pressure drop in the cold corridor",
            "Время мин перепада давления в холодном коридоре",


KNIME response:

[ [ [ "DH2.PDE01-Р'СЂРμРјСЏ РјРёРЅ РїРμСЂРμРїР ° РґР ° РґР ° РІР »РμРЅРёСЏ РІ С ... РѕР» РѕРґРЅРѕРј РєРѕСЂРёРґРѕСЂРμ in \"-1 (Р-)", "DH2.PDE01-Время РјРёРЅ перепада давления РІ холодном РєРѕСЂРёРґРѕСЂРµ в„–1(Р—)", null, null, 3 ] ], null, "ru" ]



Can anyone help me with this?

I would appreciate :)

It is fixed! :)


It was a header problem, but since postman does everything automatically i didn't noticed.

Advanced rest client was my friend here!!


Thanks anyway

Thank you for the feedback!

Cheers, Iris