GET Request

Hi Community,

I´m struggling hard with proxy settings in GET Request node, and for now I’m losing…

Please, is there any way to configure de proxy settings exclusively in the node ? I´m tryng to do it usind node -specific proxy setting option, indicating Proxy Protocol, proxy host and proxy port.“After I select Proxy host needs authentication” and select “User & password” option, indicatind Proxy User and Password.

These setting works fine if I keep Knime Analytics Platform Open but If I close and run the flow through command line, the flow doesn´t work and the GET Request related actions don´t work. Then When I open the flow again in the aplication, I can see that in GET Request Proxy Tab, the option has changed to “Use KNIME -wide proxy settings”. ¿¿¿???

If I do it through Credentials works fine but I need to run the flow in a not assisted way trouhg comman line so credentials is not a valid option.

Please help. I need to understand how these settings works in the node.

Thank you very much

Dear @JEMN,

which AP version are you using? What you are describing sounds similar to bug that was just recently fixed for 5.1.2 (and upcoming 5.2.0). There, specifically the proxy credentials were not saved consistently, so that after loading the workflow again - via GUI or command line - it may be that the proxy credentials in REST client nodes were lost. See bug AP-21244 in the 5.1.2 changelogs.

If you are using 5.1.0 or 5.1.1, it is very likely that your issue is caused by this bug. If possible, try upgrading and check if your issue persists.



Hi leon,

that was exactly the problem. Updated to version 5.1.2 and problem solved.

Thank you very much.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.