getRequest Node is giving timeout error

hi All ,

I have a workflow which reads data from a site through rest API .
It is using getRequest node to do that .

TIme to time workflow fails with below error :

WARN GET Request 4:616:588:407:10:15 Call #1 failed: java.util.concurrent.ExecutionException: SocketTimeoutException invoking http://ontrack- Read timed out
WARN JSON To XML 4:616:588:407:10:6 No JSON columns! Use for example the “String to JSON” node to create one.

Can anyone help please , I am very new to knime .
I tried to increase the timeout option , but changing that when the node resets , it changes the URL column back to default ( google) and I am not able to change it to next option ( URL column).

Is the URL coming in as an input to the Get node, or are you typing/pasting it in?

If you are pasting it in, then after setting the URL value, you should be able to increase the timeout from 2 seconds to a larger value.