Getting an error on a workflow that worked previously - "Exception while accessing file...Invalid distance code"


I am experiencing a new problem relatively frequently.  I am running version 3.4.1 (also tried 3.4.2) on a Mac.  When I am working on a workflow that has run successfully in the past, I am now getting errors that cause the workflow to fail.

Here is an example of the error message:

Execute failed: Exception while accessing file: "/Users/mwarburton/Box Sync/Knime/knime-workspace/Medaillia Org Hierarchy and User files for SFTP/Database Reader (#3870)/port_1/": invalid distance code

In some cases, I can reset all of the nodes, or re-create the problem node and it solves the problem temporarily.  But the problem comes back when I re-run it in the future.  Also, it is not always the same node that fails.  It can be the third node in the workflow, or the 10th node.  It is not consistent.

I never saw this problem until this week and I have been running the same version of Knime for a while.

Any thoughts on the cause of the problem and possible solutions?

This sounds like the same problem discussed in