Google Address Geocoder (Pallidian) rate limit exceeded error

My workflow using the GoogleAddressGeocoder is generating the error “Over_Query_Limit”.
GoogleAPI site says this occurs when the requests per second limit is exceeded.
“Note that the server-side API is limited to 50 requests per second.”
How can the API request rate be adjusted in KNIME?

Unfortunately, all those APIs keep changing their rate limits now an then. (this is very frustrating!)

We might introduce a custom rate limit setting at some point (when I have lots of time).

In the meantime, I suggest: Build the rate limiting in the workflow yourself by using one of the “Wait” nodes combined with a chunk loop, and thus have some throttling between requests.

– Philipp