google address geocoder

Hi,
I am learning to use geo nodes. When I tried to execute Google Address Geocoder, always it is reported " ERROR Google Address Geocoder 0:14 Execute failed: ws.palladian.extraction.location.geocoder.GeocoderException: Encountered HTTP exception for “https://maps.googleapis.com/maps/api/geocode/json?address=Crowea+Pl%2C+Frenchs+Forest+NSW+2086&sensor=false&key= …”. I have entered the API key in Preferences—>Palladian Geocoders. Someone has an idea?

Lei

Hi Lei,

this rings a bell – could you please have a look at this thread:

Please keep me posted here.

– Philipp

hi Philipp,
thanks for your suggestions. I checked API, it showed enabled there, but I am not totally sure. I have the debug responses in the attachment (.txt), would you please have a look. I …ehhh…do not understand them :joy: :sob:.

2020-01-30 geo node debug.txt (4.6 KB)

1 Like

Thanks for the details, Lei. From looking at the log, my first, most likely assumption is a network issue. Are you behind a corporate proxy or firewall? Do other nodes or functionalities which require a network connection inside KNIME work?

If your network setup requires a proxy configuration, please check the preferences -> General -> Network Connection and ask your network administrator about the setup.

To further diagnose: Could you try executing the attached test workflow and let me know the outcome? (it’ll simply perform a GET on two example URLs, one through HTTP and one through HTTPS)

– Philipp

1 Like

well, Philipp, you are right. I have to use a proxy, otherwise no way to access Google in China…I do not know how to solve it. I will try. Naja, please see the outcome in the attachment (.txt).
2020-01-30 test.txt (2.0 KB)