Google Analytics Connection can't connect to Google API

Hey everyone! This is my first time posting in the forum but I’ve been reading through other posts for a while so I was hoping I might find some help here.
I have a workflow with a Google Analytics connection as shown in the image below:
image
I’ve used this workflow for months to funnel GA data into our warehouse and never had any problems. However suddenly this week the Query node started failing with an error 403. The Connection and Query nodes also display a warning that they could not connect to the Google API.
image (1)
I was previously using an older version of KNIME - after encountering this issue I updated to 4.5.2 thinking that might help, but the error persists.
I’ve checked to make sure the API is enabled in GCP, ensured I have proper permissions and that the service account has proper permissions (this error also occurs when I try to connect with the API auth node instead). I tried reinstalling the software. I ensured the right scopes are set. Made sure the proper extensions were installed. I’m really boggled by this because as far as I know none of the settings in GCP were changed, but this workflow that has run flawlessly for months is suddenly bugging out on me.
Has anyone else experienced a similar issue? What else can I try to make this work?

Hi @stephaniebeagle and welcome to the Knime Community.

Just to be sure, you are re-executing the whole workflow, that is you are re-establishing the Connection, correct, and not just re-executing the Node 3, is that correct?

A 403 sounds like a permission issue (access denied). Could it be a configuration issue in your Google account?

Someone suggested to add “the email address for my service account to the Google Analytics profile I wanted it to access.” and that worked.

Thanks for the reply @bruno29a :slight_smile: Yes I am re-executing the whole workflow and I have even gone so far as building an entirely new duplicate workflow but still no luck. I also already made sure that the service account was added as a user on the Google Analytics profile and granted the right permissions (read and analyze).