Google API: Sheets updater saves values as strings

#1

This topic was covered once before a year ago. But the fix recommended does not seem to apply to the newest google sheets API. I use the Google Authenticate node, then the google sheets connector and then a Sheets Updater node. Google taking my Decimal fields and making them text by applying the ’ in front of them.

Original Post: Google API: Sheets updater saves values as strings

The google API says there is a parameter VALUE INPUT OPTION to correct that behavior but its not exposed in the knime node.

https://developers.google.com/sheets/api/reference/rest/v4/ValueInputOption

The solution prior used the depricated google sheets ervice provider. I tried that using the writeRaw=false but that did not help. Is there a similar solution with the newer authentication and sheets connectors?

FYI: The old solution works on on a Google Sheets Writer, but not on the Google Sheets Updater.

0 Likes

#2

Hi there @ScottMcLeodPSLGroup ,

just tried it and provided solution (setting writeRaw to false using flow variable) works with Google Sheets Updater node for me.

Br,
Ivan

0 Likes

#3

Your going to think I’m insane, but this morning its working for me also. I don’t understand why. It seemed the new authentication nodes were blocking it somehow but I was obviously wrong. Thank you for checking. It works for me correctly now.

1 Like

#4

No problem. Happen to me couple of times as well :smiley:

0 Likes