Google Auth (API Key) does not word=k

Hi all,

I have issues with the Google Authenticator (API Key). In the past it worked, but now it doesn’t work anymore. I’ve tried to create a new project in google console with a new service account and P12 key, but that also does not work. The steps below I’ve all went through (now for the second time):

  1. Create a new project, by clicking ‘CREATE PROJECT’: Google Cloud Platform
  2. Wait until it’s created, refresh the site. Now click on your project, this will take you here (you can see your selected project on the top of the page): Google Cloud Platform
  3. On the left side you will see Service Accounts, go there: Google Cloud Platform
  4. Create a service account by clicking on ‘Create service account’. Give it your desired name.
  5. You will see your service account, you can then create a key for it by clicking on the dots to the right of it, choose the P12 format.
  6. Now you need to enable the Google Analytics API for your project. To do This go here and press enable: Google Cloud Platform

So I have now 2 service accounts that have access to Google Analytics. With the old service account the node gives a green light, but when I connect the Google Analytics Connection node it gives a warning that it could not connect to the API. With the new service account I can’t even get the Google Authentication (API Key) node working. It contains the new service account and new P12 key. I’m sure I have the right parameters but it says: “ parseAlgParameters failed: Objectidentifier() – data isn’t an object ID (tag = 48)”. I have no idea what this means or how to fix.

I’m on KNIME version 4.3.2

Can anybody help?

Winanda Sheombarsing

Hello @Winanda,

Have you done KNIME update or changed any preferences? If that is not the case and it just stopped working I suspect issue could be as well on Google’s/service account side.

KNIME version 4.3.x is based on Java 8 (from version 4.4.0 it’s Java 11) and from error message (and with a help from google) seems Java 8 doesn’t support PKCS12 encryption (used for P12 key). Maybe you can give it a try with latest KNIME version?



Hi Ivan,

Thanks for your answer. I updated to KNIME 4.4.1 and the Google Authentication (API Key) now “works”. I gives a green light. However when I connect to the Google Analytics Connection node it gives a warning that it could not connect to the API:



Hello @Winanda,

Can you check KNIME log for more details? First configure log level to DEBUG, run nodes and then check knime file on following location: ...\knime-workspace\.metadata\knime\

(Log level is configured from within KNIME File --> Preferences --> KNIME.)

Also is it only Google Analytics to which you are not able to connect or other Google services as well?


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.