Google authenticator+google sheets reader problems

I’m reading data from google sheets. I’ve made it thousand times, but now with Knime 5.2 I encounter problems.
Google authenticator doesn’t keep the credentials when I use “interactive” mode, and I need to re-authenticate each time I launch Knime.

I tried to authenticate with API credential, but the format between Google Cloud Console and Knime doesn’t seem to match.

And when I reauthenticate, the second following node, google sheets reader is bugging (does not find the preconfigured sheet, don’t let me to change it). I have to remove it, put a new one, and reconfigure it. Has anybody encountered the same ? Any idea how to solve it ?

Thanks, have a good day.

Hi @Raphaelluce -

Just to be clear, this was something that was working before in previous version of KNIME, that is now behaving differently in 5.2? Let me ask one of my colleagues to take a closer look.

hi. Thanks for your answer.
Yes, that script worked in version 4 and i used to launch it through command line.
Now it does not function anymore with version 5. The google authenticator does not have the same fields/authentification methods and I can’t get it to keep the credential in order to be able to lauch the whole graph after a reset or to lauch it by command line.

Hi @Raphaelluce -

Here’s what I heard back. I hope it gets you on the right track!

With AP 5.2.0 we wrote a new Google Authenticator node. We removed the option to store the access token because of security concerns. But old workflows that use the “Google Authenticator (deprecated)” node should continue to work.

That said, I would encourage the user to


In Google Drive/Docs:

  • share the folder/sheets with the email address of the service account

In KNIME’s Google Authenticator node (the new one):

  • select API Key authentication
  • provide the JSON key file
  • select Google Sheets from the list of standard scopes

I cannot find how to download a json key for a service account in google cloud console.
It is possible to download a ID Clients Oauth in json, but not for a service account. For a service account the key is shown, but you cannot download it in Json.
Hav you an example of a service account json file in order I type in my credentials ?
Thanks. Have a good day.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.