Google Big Query - P12 file created from JSON giving "keystore password incorrect"


I’ve seen several posts here that loosely relate to my issue, but I wasn’t able to figure out what I am missing to get it working.

To access my Google Big Query tables, it was given to our service account a credentials.json file, that I use as a file on PowerBI and Tableau, for example. I saw that this file is currently not supported by this extension. Our IT department cannot provide me a P12 file. No reason given from their side.
So I searched on how to create a P12 file from the JSON, and after digging and creating the .pem and .cer I was able to create the P12 using this command:
openssl pkcs12 -inkey privatekey.pem -in cert.cer -password pass:changeit -export -out key.p12

As stated on the command, I’ve set the password to “changeit”, as seen on some other threads, but even though it is correct, the error is still showing.
WARN Google Authentication (API Key) 6:1 keystore password was incorrect
I’ve even tested this p12 file on the KeyStore Explorer and it’s a valid PKCS #12 with the password changeit.

Could you please help me to figure out, what I am still missing for this to work?

Thank you!

Currently the Google Auth node only supports a p12 file. I see two options.

  1. Ask your IT team to provide the p12 version of the JSON file you are using. (may not be possible)
  2. Use the DB connector node, and build the connection to Google BigQuery, and you can set the property to the path of your JSON file. We have an open Jira to update our node to support the json format as well as the legacy p12.

I’ve attached a simple DB connector with the JDBC properties with placeholders you can replace with your info.


GBQ_DB_Node.knwf (7.8 KB)

1 Like